#20 Can't import in Python 2.6.4 (Mac OS X Snow Leopard 10.6.2)

v1.0_(example)
closed
Oleg Pudeyev
None
5
2013-12-15
2010-02-27
Anonymous
No

Upon trying to import pycurl:

>>> import pycurl
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: dlopen(/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/pycurl.so, 2): Symbol not found: _CRYPTO_num_locks
Referenced from: /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/pycurl.so
Expected in: flat namespace
in /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/pycurl.so

Discussion

  • Are you sure your copy of curl was compiled with proper SSL support?

     
    • assigned_to: nobody --> zanee
     
  • Can you explain how you exactly installed pycurl? ALso run otool and find out what missing lib is there and update this ticket? Thanks!

     

  • Anonymous
    2011-04-17

    I got this issues too
    ------
    gcc-4.2 -fno-strict-aliasing -fno-common -dynamic -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -pipe -DHAVE_CURL_SSL=1 -I/System/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -c src/pycurl.c -o build/temp.macosx-10.6-universal-2.6/src/pycurl.o
    ----
    Then
    sudo python setup.py install
    -----
    My Env version are:
    Python 2.6.1 (r261:67515, Jun 24 2010, 21:47:49) [GCC 4.2.1 (Apple Inc. build 5646)] on darwin
    ----
    I try to install from easy_install and default config for setup.py install but it got these error:

    error: Setup script exited with error: command 'gcc4.2' failed with exit status 1

     
  • Oleg Pudeyev
    Oleg Pudeyev
    2013-12-15

    • status: open --> closed
    • assigned_to: Christopher Warner --> Oleg Pudeyev
    • Group: --> v1.0_(example)