Syntax of PyCLIPS programs can be more clear (from the
Python point of view) if a Call() method is implemented
for CLIPS "callable" entities, ie. Function and Generic
Probably implementing these objects as callable
themselves (by adding a __call__ method which maps to
Call) can be also result in more PyCLIPS compact code.
The only problem that could arise by doing this, is that
readability could suffer from it.
Whatever the implementation will be, Call() (and possibly
__call__()) should accept arguments in the form (self,
*args) and not (self, *args, **kwargs), as CLIPS
functions have no named arguments.