#299 Spurious warnings with numpy

0.8.19
open
nobody
None
5
2011-11-07
2011-11-07
James
No

Using PyChecker 0.8.19, Python 2.7.2, and NumPy 1.5.1, the code

import numpy

produces the output

Processing module test (test)...
warning: couldn't find real module for class <class 'fftpack.error'> (module name: fftpack)
warning: couldn't find real module for class <class 'lapack_lite.LapackError'> (module name: lapack_lite)
warning: couldn't find real module for class <type 'mtrand.RandomState'> (module name: mtrand)
warning: couldn't find real module for class <type 'mtrand.RandomState'> (module name: mtrand)

Warnings...

Discussion

  • traims
    traims
    2013-02-19

    The output is the same for newer versions of Python and NumPy (Python 2.7.3 and NumPy 1.7.0).
    PyChecker is still 0.8.19.