no problem, glad you got it fixed!

guess weird things happen if you put all of your eggs in the same basket.

-Thadeus

http://thadeusb.com


Jean Anouilh  - "What you get free costs too much."

On Fri, Mar 13, 2009 at 7:08 AM, Mauro Bianchi <bianchimro@gmail.com> wrote:
Hi, I solved my problem,

it was mainly a problem about eggs file.

moreover, I imported mechanize as Clientcookie, as  Clientcookie is part of mechanize now.
I reinstalled mechanize with the easy_install and the --always-unzip flag

thanks a lot for your help
mauro


2009/3/13 Thadeus Burgess <thadeusb@thadeusb.com>
Is there a possibility of multiple python versions on your machine?


Are you using any IDE? ( i know netbeans likes to default to jython )

and You might could try GUI2exe and see if it works.

http://xoomer.virgilio.it/infinity77/main/GUI2Exe.html
http://code.google.com/p/gui2exe/

From a google search it looks like others have had this problem in the past

http://www.nabble.com/Py2exe-and-Module-Error...-td20121063.html

You might want to try to email vince and see if he ever solved the problem.


-Thadeus

http://thadeusb.com


Joan Collins  - "The problem with beauty is that it's like being born rich and getting poorer."

On Fri, Mar 13, 2009 at 2:35 AM, Mauro Bianchi <bianchimro@gmail.com> wrote:
from distutils.core import setup
import py2exe
import ClientCookie

setup(windows=[{"script":"ryanwindow.pyw"}],options={"py2exe":{"includes":["sip"], 'packages': ['ClientCookie',]}})




--
Mauro Bianchi
bianchimro@gmail.com