Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Getting "Error 610: G_GEO_BAD_KEY...

Help
Marcelo
2013-04-07
2013-05-11
  • Marcelo
    Marcelo
    2013-04-07

    Hi, I\'m getting an \"Error 610: G_GEO_BAD_KEY\" when I try to use this wrapper.

    I\'m not sure if whether I don\'t have the right API key or whether this wrapper doesn\'t work with the Google Maps API v3.

    I tried using both an API \"Key for browser apps (with referers)\" and an API \"Key for server apps (with IP locking)\" and still get the same error.

    I\'ve tried the same examples in the documentation and I cannot make it work. I appreciate any help :)

    Thanks

     
  • Doctor J
    Doctor J
    2013-05-11

    Hi Marcelo,

    The V2 API, used by this library, has been deprecated by Google. I recommend switching to the new V3 API, and there is a Python module for that:

    https://pypi.python.org/pypi/pygeocoder

    Best of luck.