#124 RC1 startup error

v0.39.2
closed-duplicate
5
2007-04-02
2007-03-29
stffn
No

Starting up Pd-0.39.2-extended-RC1 gives this error:

error: to function, this needs to be compiled against Pd 0.40 or higher, or a version that has sys_register_loader()

It is the build from http://autobuild.puredata.info/auto-build/2007-03-28/. The testing platform is a Macbook Dual Core (not the dual 2 core, or what ever the newer one is called) running Mac OS 10.4.9.

The objects delread/delwrite and sqrt don't work as with test7. See [1] for details which still accounts. It has been mentioned that cd~ also don't work. I have not tested that.

[1] http://sourceforge.net/tracker/index.php?func=detail&aid=1645862&group_id=55736&atid=478070

Discussion

  • Logged In: YES
    user_id=27104
    Originator: NO

    An example patch is always very helpful, especially if it triggers the problem every time that it is run. Ideally the example patch would have only enough objects to cause the problem, but nothing else.

     
  • Logged In: YES
    user_id=27104
    Originator: NO

    This seems to be multiple unrelated bugs. Each bug should be posted in a separate bug report, and if possible added to any relevant, existing bug reports, like delread/delwrite.

     
    • summary: RC1 startup error, delread~/write~, sqrt~ defunct --> RC1 startup error
    • status: open --> closed-duplicate
     
  • stffn
    stffn
    2007-04-03

    Logged In: YES
    user_id=1658640
    Originator: YES

    I think they are unrelated bugs. So, sorry for posting them together. They were intelmac-RC1 specific.

    As for an example patch. To get the error mentioned, there need no patch at all. It's just a matter of starting up Pd and watch the console windue.

    And just to get it straight, it was of cause vd~ and not cd~ that also had problems.

     


Anonymous


Cancel   Add attachments