#1091 crash when Sample Rate of audio interface is changed


Pd-vanilla 0.44 and Pd-extended on OS X crash when the Sample Rate of the external audio device is changed. It freezes when the Sample Rate of the internal audio card is changed.
(Tcl) INVALID COMMAND NAME: invalid command name "Pt_Start()"
while executing
"Pt_Start() called"
("uplevel" body line 1)
invoked from within
"uplevel #0 $docmds"


  • i don't really think that there is a difference between "internal" and "external" audio device (Pd doesn't know at all, whether your soundcard is on the same board as the CPU or whether it is connected via a PCI or quakewire bus).
    so it would be interesting to know which exact devices you are experiencing problems with.

    also it's weird that you seem to get a tcl/tk error.

  • max

    I must add, I am changing the sample rate externally, not through Pd. here is a screen cast. first i try pd vanilla then pd-extended. in this case i'm changing the sample rate of the internal soundcard. results are different when i change the sr of the esternal soundcard (Fireface UCX). http://www.youtube.com/watch?v=Vb2qYRHIg8g

  • I think I have the Pt_Start stuff suppressed but OTOH can't recreate any problems changing sample rate on the fly.


  • Anonymous

    I just had the same issue. I am launching an audio file from Csound using the csoundapi~ object and it seems really out of place. The sample rate is fixed in Csound and for some reason it says it changes. Considering I am launching several samples, it is only a particular set. They could be the issue but this has never happened to me before. Any new additions.



Cancel   Add attachments