Home

Genmei Mori

Really sorry, everyone.
This project contains serious vulnerability. Please stop using.
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-4504


UPnP IGD (Internet Gateway Device).This emulates Microsoft ICS service.
This is for Kernel 2.2.
If you looking for 2.4 version,
I gave my all result to "Linux-IGD" project.
I am thankful to them who translated my project into mainstream kernel.


Project Admins: