Makefile.darwin

2007-02-26
2013-04-22
  • Queen Victoria
    Queen Victoria
    2007-02-26

    dear people .
    the install file mentions using Makefile.darwin for compiling under os x . unfortuantely, neither 1.7.0 nor 1.6.3 contain this file . i have tried uncommenting the following line from the included makefile, with no greater success .

    # DARWIN
    CFLAGS += -DDARWIN

    any advice would be greatly appreciated .

    ________________
    here is my error
    whale:~/Desktop/proxytunnel-1.7.0 rossetti$ make
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o proxytunnel.o proxytunnel.c
    proxytunnel.c: In function 'do_daemon':
    proxytunnel.c:250: warning: pointer targets in passing argument 3 of 'accept' differ in signedness
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o base64.o base64.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o strlcpy.o strlcpy.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o strlcat.o strlcat.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o setproctitle.o setproctitle.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o io.o io.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o http.o http.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o basicauth.o basicauth.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o readpassphrase.o readpassphrase.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o messages.o messages.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o cmdline.o cmdline.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o ntlm.o ntlm.c
    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o ptstream.o ptstream.c
    cc -o proxytunnel -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN proxytunnel.o base64.o strlcpy.o strlcat.o setproctitle.o io.o http.o basicauth.o readpassphrase.o messages.o cmdline.o ntlm.o ptstream.o -lssl -lcrypto
    /usr/bin/ld: warning multiple definitions of symbol _strlcpy
    strlcpy.o definition of _strlcpy in section (__TEXT,__text)
    /usr/lib/gcc/i686-apple-darwin8/4.0.1/../../../libSystem.dylib(strlcpy.So) definition of _strlcpy
    /usr/bin/ld: warning multiple definitions of symbol _strlcat
    strlcat.o definition of _strlcat in section (__TEXT,__text)
    /usr/lib/gcc/i686-apple-darwin8/4.0.1/../../../libSystem.dylib(strlcat.So) definition of _strlcat

    ________________
    here is my system

    intel core 2 duo
    os x 10.4.8
    Darwin whale.local 8.8.3 Darwin Kernel Version 8.8.3: Wed Oct 18 21:57:10 PDT 2006; root:xnu-792.15.4.obj~4/RELEASE_I386 i386 i386

    ________________
    gcc

    Using built-in specs.
    Target: i686-apple-darwin8
    Configured with: /private/var/tmp/gcc/gcc-5367.obj~1/src/configure --disable-checking -enable-werror --prefix=/usr --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/lib --build=powerpc-apple-darwin8 --with-arch=nocona --with-tune=generic --program-prefix= --host=i686-apple-darwin8 --target=i686-apple-darwin8
    Thread model: posix
    gcc version 4.0.1 (Apple Computer, Inc. build 5367)

    ________________
    darwin (mac) ports

    The following ports are currently installed:
      bzip2 @1.0.4_0 (active)
      expat @2.0.0_1 (active)
      gettext @0.16.1_0 (active)
      gnupg @1.4.6_0 (active)
      gnutls @1.4.1_0+darwin_8 (active)
      lftp @3.5.1_0+tls (active)
      libgcrypt @1.2.2_0+darwin_8 (active)
      libgpg-error @1.3_0 (active)
      libiconv @1.11_0+darwin_8 (active)
      libpcap @0.9.4_0 (active)
      libtasn1 @0.3.4_0 (active)
      mmencode @2.7_0 (active)
      ncurses @5.6_1+darwin_8 (active)
      ncursesw @5.6_0+darwin_8 (active)
      nmap @4.10_0 (active)
      opencdk @0.5.8_0 (active)
      openssl @0.9.8d_0+darwin_8 (active)
      pcre @7.0_0 (active)
      readline @5.1.004_0 (active)
      wget @1.10.2_0+darwin_8 (active)
      zlib @1.2.3_0 (active)

     
    • Mark Janssen
      Mark Janssen
      2007-02-27

      Yeah... that's a bit outdated. The regular makefile replaced it (uncomment the darwin section)

      Since I don't have access to any darwin boxen i can't test it myself, so that explains the broken-ness... It should be easy to fix.

      As darwin apparently has strlcat included you don't need the version that comes with proxytunnel. Remove the strlcat line in the makefile and you're set.

      Probably also remove the strlcpy line if it complains about that one (as that is also a bsd-replacement function)

      Mark Janssen

       
      • Queen Victoria
        Queen Victoria
        2007-02-28

        that worked a charm, thanks mark . as you suggested, i removed ( commenting doesn't work ) the two lines referring to strlcpy and strlcat in the Makefile .

         
    • khyros
      khyros
      2007-09-12

      I'm getting this error message

      cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG  -DUSE_SSL  -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN   -c -o proxytunnel.o proxytunnel.c
      cc: installation problem, cannot exec `cc1': No such file or directory
      make: *** [proxytunnel.o] Error 1

      Any ideas how can I fix it?
      thanks

       
      • Mark Janssen
        Mark Janssen
        2007-09-12

        Please start a new thread for a new question...

        It seems your local system is missing some parts of gcc
        Besides that, you should edit and use the default Makefile these days, not Makefile.darwin