Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

ERROR: ld.so: object 'libproxychains.so.3'

bang.gh
2011-06-22
2013-05-09
  • bang.gh
    bang.gh
    2011-06-22

    $ proxychains opera
    ProxyChains-3.1 (http://proxychains.sf.net)
    ERROR: ld.so: object 'libproxychains.so.3' from LD_PRELOAD cannot be preloaded: ignored.
    $ ldd -v /usr/lib/libproxychains.so.3
    linux-vdso.so.1 =>  (0x00007fff4dfff000)
    libdl.so.2 => /lib/libdl.so.2 (0x00007fbd112a6000)
    libc.so.6 => /lib/libc.so.6 (0x00007fbd10f23000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fbd1264b000)

    Version information:
    /usr/lib/libproxychains.so.3:
    libdl.so.2 (GLIBC_2.2.5) => /lib/libdl.so.2
    libc.so.6 (GLIBC_2.4) => /lib/libc.so.6
    libc.so.6 (GLIBC_2.3.4) => /lib/libc.so.6
    libc.so.6 (GLIBC_2.2.5) => /lib/libc.so.6
    /lib/libdl.so.2:
    ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
    libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
    libc.so.6 (GLIBC_2.2.5) => /lib/libc.so.6
    /lib/libc.so.6:
    ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
    ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
    $ uname -a
    Linux test 2.6.32-32-generic #62-Ubuntu SMP Wed Apr 20 21:52:38 UTC 2011 x86_64 GNU/Linux

    I'm trying full path to libproxychains.so.3, also change to 32bit libproxychains.so.3 - nothing help.
    have any ideas?