Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#22 [r281] cannot start due to QWidget error

v1.0_(example)
open
nobody
None
5
2014-03-12
2013-04-07
eadmaster
No

uname -a

Linux puppypc1319 3.8.2-upup #1 SMP Wed Mar 13 01:01:13 GMT-8 2013 i686 athlon i386 GNU/Linux

python --version

Python 2.7.3

python -c "from PyQt4.QtCore import QT_VERSION_STR; print(QT_VERSION_STR)"

4.8.1

python procexp.py

QWidget: Must construct a QApplication before a QPaintDevice
Aborted

i've found some info about this error here:
http://www.qtcentre.org/threads/10959-QWidget-Must-construct-a-QApplication-before-a-QPaintDevice

Related

Commit: [r281]

Discussion

  • Carl Wolff
    Carl Wolff
    2013-04-12

    is a stack trace printed, or An exception?

     
  • Cybjit
    Cybjit
    2013-12-01

    I had the same error in Ubuntu, it was solved by installing python-qwt5-qt4

     
  • eadmaster
    eadmaster
    2014-03-12

    It's an exception.

    @Cybjit: i've tried what you suggested, but i still get the same error...

    side note: i've moved procexp from the default install dir ("/usr/lib/procexp"), maybe this broke something?