Glitch on Screen Flash

Help
2008-09-08
2013-06-05
  • I get an annoying pause when the screen flashes as I pick something up. Everything else seems to run smoothly. I'm in 640x480 software mode. Running at 320x240 reduces the pause a little but not all.

    I'm not running in GL mode as I find all the textures are blurred out. Is there a pixel to pixel render mode for GL ?

     
    • Hi!

      Could you tell us some more on which OS you use this and which PrBoom version you use?

      The small pause is most likely caused by the fact that the color palette changes and for some reason SDL is not using a paletted mode, but has to recalculate internal lookup tables for conversion.

      There should be a setting in the advanced setup for OpenGL to set it to point filtering instead of bilinear. I currently can't look it up and don't remember where exactly it is. You could also search the config file for LINEAR and change it to POINT.

      Regards,
      Florian Schulze

       
    • Thanks :)

      That's fixed it. I changed gl_tex_filter_string from LINEAR to POINT and now I don't get the pause.

      I still get non pixel to pixel mapped textures in opengl mode, but that might be normal I guess. I don't really notice that now without the annoying pause for some reason.

       
    • Oh I got it. Needs to be "GL _NEAREST" set in the internal menu for pixel to pixel textures. I swear I checked that before and it did'nt work ! So beware, there may be something odd going on with my setup.

       
    • Oops, forgot this ...

      glboom 2.4.7

      Windows XP Media Center Edition SP3

      AMD Sempron 3400+ 1.81 Ghz

      NVidia GeForce 6100 nForce 405