fatal: no SASL authentication mechanisms

Anonymous
2013-01-06
2013-01-23

  • Anonymous
    2013-01-06

    After following the guide provided by debuntu.org (http://www.debuntu.org/how-to-virtual-emails-accounts-with-postfix-and-dovecot/) which was very helpful, I immediately began having issues with SASL autentication. What provoked me to look in the mail.log to see the following message was an error message on thunderbird that stated "Thunderbird failed to find the settings for your email account." The error that repeats in mail.log is as follows:

    Jan  6 04:44:15 Jesse-Server postfix/smtpd[9176]: fatal: no SASL authentication mechanisms
    

    This provoked me to look for private/auth, but as you can see below, no such file exists…

    root@Jesse-Server:/home/clucky# ls -l /var/spool/postfix/private/auth
    ls: cannot access /var/spool/postfix/private/auth: No such file or directory
    

    What I would like to know is where is my private/auth folder? Am I using the wrong version of dovecot perhaps? In an unrelated note, when I type service dovecot restart it says the following:

    stop: Unknown instance:
    dovecot start/running, process 9394
    

    Here is the configuration for postfix labled main.cf:

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    # TLS parameters
    smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    #vhost with mysql params
    #virtual_alias_domains needs to be unset
    virtual_alias_domains =
    virtual_mailbox_domains = mysql:/etc/postfix/virtual/mysql-virtual-mailbox-domains.cf
    virtual_mailbox_maps = mysql:/etc/postfix/virtual/mysql-virtual-mailbox-maps.cf
    virtual_alias_maps = mysql:/etc/postfix/virtual/mysql-virtual-alias-maps.cf, mysql:/etc/postfix/virtual/mysql-virtual-email2email.cf
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    virtual_transport = dovecot
    dovecot_destination_recipient_limit = 1
    myhostname = worldofclucky.net
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = worldofclucky.net, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    smtpd_sasl_auth_enable = yes
    smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_unauth_destination
    

    and here is dovecot.conf:

    protocols = imaps
    mail_location = maildir:/var/vmail/%d/%n/Maildir
    ## uncomment this if you already have email from
    ## courier for instance.
    #namespace private {
    #  separator = .
    #  prefix = INBOX.
    #  inbox = yes
    #}
    ## change section "protocol lda" to:
    protocol lda {
      # Address to use when sending rejection mails.
      postmaster_address = postmaster@worldofclucky.net
      log_path = /var/vmail/dovecot-deliver.log
      # Hostname to use in various parts of sent mails, eg. in Message-Id.
      # Default is the system's real hostname.
      #hostname =
      # Support for dynamically loadable plugins. mail_plugins is a space separated
      # list of plugins to load.
      #mail_plugins =
      #mail_plugin_dir = /usr/lib/dovecot/modules/lda
      # Binary to use for sending mails.
      #sendmail_path = /usr/lib/sendmail
      # UNIX socket path to master authentication server to find users.
      auth_socket_path = /var/run/dovecot/auth-master
      # Enabling Sieve plugin for server-side mail filtering
      # handy for storing spam in their folders
      mail_plugins = cmusieve
      global_script_path = /var/vmail/globalsieverc
    }
    ## in section auth default
    ## change :
    mechanisms = plain login
    ## comment out "passdb pam"
    ## and make sure the following is in
    ## to look for users in the DB
      passdb sql {
        # Path for SQL configuration file, see /etc/dovecot/dovecot-sql.conf for example
        args = /etc/dovecot/dovecot-sql.conf
      }
    ## and add this so dovecot does not deal with uid/gid
    ## we use uid and gid 5000 for everybody
      userdb static {
        args = uid=5000 gid=5000 home=/home/vmail/%d/%n allow_all_users=yes
      }
    ## next make sure the section "socket listen" looks like this
    ## so dovecot and postfix work happily together
      socket listen {
         master {
           path = /var/run/dovecot/auth-master
           mode = 0600
           user = vmail # User running Dovecot LDA
           #group = mail # Or alternatively mode 0660 + LDA user in this group
         }
         client {
          # The client socket is generally safe to export to everyone. Typical use
          # is to export it to your SMTP server so it can do SMTP AUTH lookups
          # using it.
          path = /var/spool/postfix/private/auth
          #path = /var/run/dovecot/auth-client
          mode = 0660
          user = postfix
          group = postfix
         }
       }
    

    Any help would be greatly appreciated, and if you need any more errors/configs, do not hesitate to ask. Thank you in advanced!

     

  • Anonymous
    2013-01-06

    I acciently posted mail.err, not mail.log… Here is mail.log

    Jan  6 14:16:45 Jesse-Server postfix/smtpd[22109]: connect from unknown[192.168.2.1]
    Jan  6 14:16:45 Jesse-Server postfix/smtpd[22109]: warning: SASL: Connect to private/auth failed: No such file or directory
    Jan  6 14:16:45 Jesse-Server postfix/smtpd[22109]: fatal: no SASL authentication mechanisms
    Jan  6 14:16:46 Jesse-Server postfix/master[8209]: warning: process /usr/lib/postfix/smtpd pid 22109 exit status 1
    Jan  6 14:16:46 Jesse-Server postfix/master[8209]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jan  6 14:17:46 Jesse-Server postfix/smtpd[22134]: connect from localhost[127.0.0.1]
    Jan  6 14:17:46 Jesse-Server postfix/smtpd[22134]: warning: SASL: Connect to private/auth failed: No such file or directory
    Jan  6 14:17:46 Jesse-Server postfix/smtpd[22134]: fatal: no SASL authentication mechanisms
    Jan  6 14:17:47 Jesse-Server postfix/master[8209]: warning: process /usr/lib/postfix/smtpd pid 22134 exit status 1
    Jan  6 14:17:47 Jesse-Server postfix/master[8209]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jan  6 14:18:26 Jesse-Server postfix/anvil[22112]: statistics: max connection rate 1/60s for (smtp:192.168.2.1) at Jan  6 14:16:45
    Jan  6 14:18:26 Jesse-Server postfix/anvil[22112]: statistics: max connection count 1 for (smtp:192.168.2.1) at Jan  6 14:16:45
    Jan  6 14:18:26 Jesse-Server postfix/anvil[22112]: statistics: max cache size 1 at Jan  6 14:16:45
    
     

  • Anonymous
    2013-01-07

    Nobody know how?

     
  • Charles
    Charles
    2013-01-07

    Well…

    First, this is not a postfixadmin issue, it is a postfix/sasl issue…

    Second, I know nothing about Debian, except that it is infamous for chrooting postfix which causes a lot of people new to postfix lots of headaches…

    Third - never provide copy/paste from config files - for postfix, only provide UNTRIMMED postconf -n output, for dovecot, doveconf -n output…

    Anyway, it looks to me like you postfix is chrooted… change the y to an n in the chroot column in master.cf and restart postfix…

     

  • Anonymous
    2013-01-08

    I do not see a "y", only dashes and "n"… :( Would you like me to submit this file? Also, the postfix -n output doesn't work, it just says "unknown parameter: output," and doveconf -n output doesn't work either, it says no permission.

     
  • Charles
    Charles
    2013-01-08

    If it doesn't have an 'n' under the chroot column then it is chrooted.

    I said postCONF -n, not postFIX -n…

    Run doveconf -n as root…

     

  • Anonymous
    2013-01-08

    Oh, sorry about that… So do I change all of the dashes to n in master.cf, or some of them? Sorry, I'm very confused…

    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #smtp      inet  n       -       -       -       1       postscreen
    #smtpd     pass  -       -       -       -       -       smtpd
    #dnsblog   unix  -       -       -       -       0       dnsblog
    #tlsproxy  unix  -       -       -       -       0       tlsproxy
    #submission inet n       -       -       -       -       smtpd
    #  -o syslog_name=postfix/submission
    #  -o smtpd_tls_security_level=encrypt
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    #smtps     inet  n       -       -       -       -       smtpd
    #  -o syslog_name=postfix/smtps
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    #628       inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       n       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    proxywrite unix -       -       n       -       1       proxymap
    smtp      unix  -       -       -       -       -       smtp
    relay     unix  -       -       -       -       -       smtp
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    retry     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # ====================================================================
    #
    # Recent Cyrus versions can use the existing "lmtp" master.cf entry.
    #
    # Specify in cyrus.conf:
    #   lmtp    cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
    #
    # Specify in main.cf one or more of the following:
    #  mailbox_transport = lmtp:inet:localhost
    #  virtual_transport = lmtp:inet:localhost
    #
    # ====================================================================
    #
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    #
    #cyrus     unix  -       n       n       -       -       pipe
    #  user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # ====================================================================
    # Old example of delivery via Cyrus.
    #
    #old-cyrus unix  -       n       n       -       -       pipe
    #  flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
    #
    # ====================================================================
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix  -   n   n   -   2   pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    dovecot   unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient}
    

    Also, none of those -n outputs seem to be working… And I probably have the wrong config vesion for Dovecot, but I'm not sure… (I copied and pasted from the tutorial like it said to do)

    Doveconf -n root

    doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
    doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1: 'imaps' protocol is no longer supported. to disable non-ssl imap, use service imap-login { inet_listener imap { port=0 } }
    doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 29: Unknown setting: global_script_path
    doveconf: Error: managesieve-login: dump-capability process returned 89
    doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
    doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1: 'imaps' protocol is no longer supported. to disable non-ssl imap, use service imap-login { inet_listener imap { port=0 } }
    doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 29: Unknown setting: global_script_path
    

    postconf -n output

    postconf: warning: output: unknown parameter
    
     
  • Charles
    Charles
    2013-01-08

    Just change the '-' on the smtp line under the chroot column to an 'n'…

    But, you really, really need to be asking for help on the debian list. I don't do debian (I'm a gentoo guy), and my understanding is they have their own ways of doing things.

    What happens when you type 'postconf -n'?

    You only pasted a few lines from the doveconf -n output… please paste ALL of it (same for postconf -n output)…

     

  • Anonymous
    2013-01-08

    Oh sorry, it seems I ommitted a line by accident on the doveconf. So should I make a new thread in the debian category? That would be duplicating a thread, would it not?

    mail.log

    Jan  8 18:04:44 Jesse-Server postfix/master[552]: daemon started -- version 2.9.3, configuration /etc/postfix
    Jan  8 18:05:40 Jesse-Server postfix/tlsmgr[630]: warning: request to update table btree:/var/spool/postfix/smtpd_scache in non-postfix directory /var/spool/postfix
    Jan  8 18:05:40 Jesse-Server postfix/tlsmgr[630]: warning: redirecting the request to postfix-owned data_directory /var/lib/postfix
    Jan  8 18:05:40 Jesse-Server postfix/tlsmgr[630]: warning: request to update table btree:/var/spool/postfix/smtp_scache in non-postfix directory /var/spool/postfix
    Jan  8 18:05:40 Jesse-Server postfix/tlsmgr[630]: warning: redirecting the request to postfix-owned data_directory /var/lib/postfix
    Jan  8 18:05:45 Jesse-Server postfix/smtpd[628]: connect from unknown[192.168.2.1]
    Jan  8 18:05:45 Jesse-Server postfix/smtpd[628]: warning: SASL: Connect to private/auth failed: No such file or directory
    Jan  8 18:05:45 Jesse-Server postfix/smtpd[628]: fatal: no SASL authentication mechanisms
    Jan  8 18:05:46 Jesse-Server postfix/master[552]: warning: process /usr/lib/postfix/smtpd pid 628 exit status 1
    Jan  8 18:05:46 Jesse-Server postfix/master[552]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    

    Postconf -n

    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    config_directory = /etc/postfix
    dovecot_destination_recipient_limit = 1
    inet_interfaces = all
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    mydestination = worldofclucky.net, localhost
    myhostname = worldofclucky.net
    mynetworks = 127.0.0.0/8
    myorigin = /etc/mailname
    recipient_delimiter = +
    relayhost =
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_path = private/auth
    smtpd_sasl_type = dovecot
    smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtpd_use_tls = yes
    virtual_alias_domains =
    virtual_alias_maps = mysql:/etc/postfix/virtual/mysql-virtual-alias-maps.cf, mysql:/etc/postfix/virtual/mysql-virtual-email2email.cf
    virtual_gid_maps = static:5000
    virtual_mailbox_domains = mysql:/etc/postfix/virtual/mysql-virtual-mailbox-domains.cf
    virtual_mailbox_maps = mysql:/etc/postfix/virtual/mysql-virtual-mailbox-maps.cf
    virtual_transport = dovecot
    virtual_uid_maps = static:5000
    

    Doveconf -n

    # 2.0.19: /etc/dovecot/dovecot.conf
    doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
    doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1: 'imaps' protocol is no longer supported. to disable non-ssl imap, use service imap-login { inet_listener imap { port=0 } }
    doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 29: Unknown setting: global_script_path
    doveconf: Error: managesieve-login: dump-capability process returned 89
    doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
    doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1: 'imaps' protocol is no longer supported. to disable non-ssl imap, use service imap-login { inet_listener imap { port=0 } }
    doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 29: Unknown setting: global_script_path
    
     

  • Anonymous
    2013-01-08

    Oh, i forgot to mention that I did chroot smtpd prior to restarting.

     
  • Simon Hobson
    Simon Hobson
    2013-01-09

    > So should I make a new thread in the debian category? That would be duplicating a thread, would it not?

    No, what libertytrek is saying to you is that this is the help forum for a package called Postfix Admin (aka PFA). PFA is a package which works with Postfix to provide an easy to use way to manage virtual domains, mailboxes, and aliases.
    This is NOT a general support forum for Postfix itself. While we are (by definition) Postfix users in order to use PFA, we are (mostly) not Postfix experts.

    Your question is not connected in any way to PFA, thus you are asking in the wrong place.
    You would do better asking in a forum dedicated to Postfix (see over at postfix.org), or probably better still asking in a Debian or Ubuntu (you haven't specified what OS you are using) specific forum. As libertytrek says, Debian do tend to change things - in this case running Postfix chroot by default (which is a security enhancement and shouldn't just be considered a nuisance to be turned off) and so you are more likely to get sensible help in a Debian (or Ubuntu) help forum.

    However, given what that howto shows you how to do, have you not considered looking at PFA ? It does what that setup does - and a lot more - but also includes an easy to use web GUI.
    If you do decide to try it, you must revert your current setup back to "as installed". Do NOT try and go from where you are now and add the PFA setup - that is guaranteed to cause problems.

    I'm afraid I can't be much help with your problem. But right at the start of your first post, you look for private/auth ? Where does that come from since it's not mentioned in the log snippet you post ? I've only setup Postfix/SASL with Courier - and from memory it required installing libsasl2-2 or you might have SASL support, but authentication mechanisms. I also vaguely (it's been a while) having to make minor edits where two different packages have used different locations for a unix socket which needs a minor config edit in one of them. Smtpd is chroot by default, something like /var/lib/postfix - and the startup takes care of copying everything it needs IIRC. But when integrating with third parties, you may need to adjust the config so the third party puts it's communications socket within the Postfix chroot.

     
  • Charles
    Charles
    2013-01-09

    > As libertytrek says, Debian do tend to change things - in this case running Postfix chroot by default (which is a security
    > enhancement and shouldn't just be considered a nuisance to be turned off) and so you are more likely to get sensible
    > help in a Debian (or Ubuntu) help forum.

    Actually, Wietse Venema (postfix's author) does indeed recommend against running postfix chroot'd unless you know exactly what you are doing and *why* you need to run it chroot'd. He says that in most cases it does *not* provide any additional security. Postfix is designed to be secure by default. In fact he said that a poorly chroot'd system can be *less* secure.

    He has complained very loudly about debian chrooting postfix by default and says they should not.

    As for sasl support - since he is running dovecot, he can use dovecots sasl support, but as you said, he is asking for help in the wrong place.

    I recommend the OP start over, then do things methodically…

    1. Get postfix working and delivering mail.

    2. Install dovecot and get it working.

    3. Switch to the dovecot LDA (or LMTP) for delivery.

    4. Turn on dovecot-sasl

    Ask for help on the individual support lists along the way - although, again, since you're running debian, you may be better of asking on one of their support lists.

     

  • Anonymous
    2013-01-09

    Strangely enough, I've posted this on the ubutnu forums and go absolutely no replies… :| Its been nearly a week since I posted there… I have tried to do it over again, uninstalling everything and then reinstalling them, the only issue is, I can't figure out how to uninstall dovecot being its not working with apt-get remove:

    root@Jesse-Server:/home/clucky# apt-get remove dovecot
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package dovecot
    
     
  • J.Kruis
    J.Kruis
    2013-01-09

    hi,

    which version ubuntu are you using.

    if you type in :

    aptitude search dovecot

    this will show al the module which can be install on your version of ubunutu.
    the one with a i in front of the line are the ones install

    aptitude purge dovecot-imapd will delete all file which belong to this module will be remove also the config files

    aptitude remove dovecot-imapd will only the module.

    if you type

    aptitude purge dovecot-core

    this will remove all dovecot include the sub modules

    Regrade
    Jan Kruis

     
  • GingerDog
    GingerDog
    2013-01-10

    Your original problem is because Postfix's SMTPD (as defined in master.cf) is chroot'ed into /var/spool/postfix

    Your options are to either stop chroot'ing smtpd in master.cf, or reconfiguring saslauthd by editing /etc/default/saslauthd and specifying within it :

    OPTIONS="-c -r -O localhost -m /var/spool/postfix/var/run/saslauthd"

    (the -m is the important bit …  )

    David.

     

  • Anonymous
    2013-01-13

    None of these fixes seem to be wanting to work, so I'm going to do like simonhobson said and try PostfixAdmin, it seems to be very nice from the looks of it, so I'm going to try to install it. Thanks for all of your help!