Unable to Log In

2013-05-08
2013-07-01
  • Jason Harrison
    Jason Harrison
    2013-05-08

    Went through the setup. The setup page says all is "Ok". Setup the setup password and placed the hashed version in the config file. Tried to setup a superuser and when clicking the "Add Admin" button the page refreshes, but fails to provide any positive feedback on success or failure. At the bottom of the page the following is displayed:

    DEBUG INFORMATION:
    Invalid query: Field 'description' doesn't have a default value

    This is Postfix Admin 2.3.6.

    Noticed there is a bug ticket for this issue also.

    When checking db tables, the admin table is not populated with any info, so unable to log in and use Postfix Admin at the moment. Still trying to determine a work around until this issue is addressed.

    If anyone has any info that may help that would be greatly appreciated.

    If I stumble across a workaround or fix in the meantime, I'll be sure to post it back here.

    -harrisontech

     
  • Interesting problem, because the admin table doesn't even have a description column. After thinking more about it, it might be the creation of the "ALL" pseudo-domain which is used as superadmin flag.

    Wild guess: in setup.php, replace (line 338)
    db_insert('domain', array('domain' => 'ALL'));
    with
    db_insert('domain', array('domain' => 'ALL', 'description' => ''));

    Does this solve the problem?

    BTW: Which database are you using? MySQL? MariaDB? PostgreSQL? Any special settings?

     
  • Jason Harrison
    Jason Harrison
    2013-05-11

    Running the latest release build of MySQL. Replaced the line. Re-ran the process and now seeing this:

    DEBUG INFORMATION:
    Invalid query: Field 'transport' doesn't have a default value

    So, this did not solve the problem, but changed it a little. :)

    Thanks Christian!

     
  • Looks like MySQL got more strict in the default settings...

    Edit setup.php again, this time use
    db_insert('domain', array('domain' => 'ALL', 'description' => '', 'transport => ''));

    If you still get similar complaints, also add those fields in the db_insert call and tell me what you need to get it working.

    Note: This issue is also handled in https://sourceforge.net/p/postfixadmin/bugs/288/

     
  • Just for the benefit of anyone else who stumbles onto this as I did. Experiencing the same issue as Jason Harrison, I first tried suggested fix #2 to remedy this issue. Fix #2 did not work for me, so I decided to give fix #1 a whirl and it DID work for me.