PostfixAdmin 2.3.6 released

2013-01-03
2013-01-23
  • We just released PostfixAdmin 2.3.6.

    It contains some small bugfixes:
      - display domain and mailbox description with correct encoding
      - fix footer link
      - focus username input field in login form
      - fix double inclusion of config.inc.php in setup.php
      - fix bool and date handling in fetchmail

    If you have at least PostfixAdmin 2.3.5 installed and are not affected by one of the bugs mentioned above, there's no urgent reason to update to 2.3.6.

    If you still have PostfixAdmin 2.3.4 or older, you should already have updated several months ago ;-) - if not, do it now!

    I'll also give a short status update on the long-awaited 3.0 release:

    First of all, you can checkout SVN trunk and test it yourself. The webinterface should be fully functional (even if there were lots of changes "under the hood"). The new commandline client is still incomplete.

    I hope to have a "3.0 preview" release in the next months, but due to lack of time I can't (and won't ;-) promise an exact date ;-)

    Oh, if you want to help, there are some easy tasks:
    - update the translation for your language (download languages/*.lang from SVN trunk, translate all lines marked with XXX and upload the file to the tracker)
    - "compress" the Changelog from ~300 lines I have in my draft to something people actually read. If you are interested, contact me and I'll send you my draft
    - and of course: checkout SVN trunk, test it, report bugs etc.

    If you want to help, but need a more detailed version of the above, feel free to ask ;-)

     

  • Anonymous
    2013-01-03

    Hi Christian,

    first of all, thank you for the update.

    One question though:
    Does the 3.0 release change the data model of the current release?

    Cheers
        Mike

     
  • There are some changes in the database layout, so you need to run upgrade.php.

    The good news is that the database is backwards compatible - basically you can use 2.3.x and SVN trunk with the same database without breaking anything. There are only two things that you better do with the SVN trunk version:
    - creating superadmins (because there's a new column to store the superadmin flag - upgrade.php "converts" existing superadmins, but won't do it again later if you add new superadmins with 2.3.x)
    - vacation start and end date are only supported in SVN trunk (and obviously you need the new vacation.pl if you want to use this feature)