Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Vacation, already notified

Vlada
2013-01-03
2013-01-23
  • Vlada
    Vlada
    2013-01-03

    Hi.
    I've configured vacation, it is working ok,  but just for first email. So, if user1@mydomain.com has Auto response enabled, and user2@mydomain.com sends an email to user1, user2 gets "Out of office" email. But if user2 sends another email to user1, nothing happens. In vacation.log there is:
    Already notified user2@mydomain.com, or some error prevented us from doing so

    In vacation.pl there is:
      if (already_notified($email, $orig_from) == 1) {
               $logger->debug("Already notified $orig_from, or some error prevented us from doing so");
                 return;
            }

    So, when first mail is sent, new row in vacation_table is added, and all succeeding email from that user are ignored.

    Is this how it should be?

     
  • Simon Hobson
    Simon Hobson
    2013-01-04

    Yes. IIRC there is either setting, or a value you'd have to change in the code, for how often a reply is sent. The idea is that if you send (say) 20 emails/day to User1, you only get one vacation message/day (or 1/period you've selected) instead of 20 (one per message sent).

     
  • Vlada
    Vlada
    2013-01-04

    Are you reffering to RC version from SVN?

     
  • It's already available in 2.3.x - $interval in vacation.pl (or /etc/postfixadmin/vacation.conf if you use an external configfile)

     
  • Vlada
    Vlada
    2013-01-04

    Thanks christian.
    In vacation.pl I have:
    # notification interval, in seconds
    # set to 0 to notify only once
    # e.g. 1 day …
    #my $interval = 60*60*24;
    # disabled by default
    our $interval = 0;

    So what is my $interval, and what is our $interval? I should comment our $interval and uncomment my $interval?
    What should I set for my $interval?

     
  • Please use "our $interval" ("my $interval" will fail if you use an external configfile - besides that, it's the same variable, and I just replaced the "my" with "our" in SVN trunk to avoid future confusion).

    You can choose the value (in seconds) for $interval as you need - if you want an autoreply to every mail, setting "our $interval = 1;" (1 second) is probably what you want.

     
  • Vlada
    Vlada
    2013-01-04

    Thanks again christian.
    This is what I want.

    So, actually, it compares sending time with time in notified_at and if it is greater then what is set as interval, it sends email? Right?

    If I set interval to 20 minutes, and send another mail after 10 minutes I'm not going to be notified again? And if I send another mail after 25 minutes I will be notified?

     
  • Charles
    Charles
    2013-01-05

    I seem to recall reading somewhere that the 'recommended setting' (I think it was one of the RFCs) is once per week (or once every 7 days).

    Personally I think this is much too long of an interval. I prefer the once per day interval.

    I would strongly recommend against setting this to reply to every email… that is just plain silly, and potentially problematic (think people who are subscribed to email lists that aren't ignored - if the list is high traffic, they will be inundating innocent list participants with auto-replies, and will most likely be forcibly unsubscribed as a result)…

    Why do you think that once per day is not enough?

     
  • Vlada
    Vlada
    2013-01-06

    Well, maybe you are right, once per day is fine. I just needed to changee default (just one reply) which isn't good for me.