#148 php >= 5.3: some functions are deprecated.

v_2.3
closed-accepted
nobody
Core (82)
5
2009-07-19
2009-07-09
Ryow
No

I equipped postfixadmin 2.3.5rc with php 5.3 and encountered some errors like this:
Deprecated: Function ereg() is deprecated in /home/httpd/vhosts/p-macle.com/postfixadmin/functions.inc.php on line 19

After php5.3, ereg() is deprecated. (I fixed this code with strcmp()).

Other deprecated functions are listed at the URL below:
http://us2.php.net/manual/en/migration53.deprecated.php

Would these future-deprecated functions be replaced to the compatible ones with the old php in the future release?

Discussion

  • GingerDog
    GingerDog
    2009-07-09

    Hi,
    Yes, removing ereg should be no hardship.I'd appreciate a patch if possible :-)

     
  • Ryow
    Ryow
    2009-07-10

    Thank you gingerdog for suggesting me make a patch. This is my first time to make a patch... but I made it anyway and uploaded.
    I don't know if it works good or not, though I tested it myself and worked fine. Please try it.

     
  • GingerDog
    GingerDog
    2009-07-19

    I believe I've made all the necessary changes to the code -at least there are no longer any ereg calls.

     
  • GingerDog
    GingerDog
    2009-07-19

    • status: open --> closed-accepted