Mac installer - CORRECTED

There was an error with the FTP upload of the earlier PostBooks for Mac installer. Please confirm that you have the latest installer, which is named PostBooks-MacOSX-Installer-2-2-1.dmg.

Thanks for your patience, and our apologies for the inconvenience!

Posted by Ned Lilly 2007-10-04