Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Startup Error !!! Help me!!!

Help
2011-10-18
2013-04-23
  • Kim Hyundon
    Kim Hyundon
    2011-10-18

    I need your guys help…… -_-;;;;

    When I double clicked pubuntu.exe file, I got errors like below log

    I think it's an error about filesystem, /tmp/pubuntu

    * log

    grep: /tmp/pubuntu/portable_ubuntu_info: Input/output error
    cat: /tmp/pubuntu/portable_ubuntu_info: Input/output error
    * Setting sensors limits                                               

    * Speech-dispatcher configured for user sessions
    * Starting Common Unix Printing System: cupsd                          
    * PulseAudio configured for per-user sessions
    * Enabling additional executable binary formats binfmt-support         

    Ubuntu 10.04.3 LTS pubuntu tty1

    pubuntu login: pubuntu (automatic login)
    Last login: Tue Oct 18 05:43:25 ART 2011 on tty1
    Linux pubuntu 2.6.33.7-co-0.7.9 #1 PREEMPT Wed Feb 16 23:51:21 UTC 2011 i686 GNU
    /Linux
    Ubuntu 10.04.3 LTS

    Welcome to Ubuntu!
    * Documentation:  https://help.ubuntu.com/

    grep: /tmp/pubuntu/portable_ubuntu_info: Input/output error
    Using authority file /home/pubuntu/.Xauthority
    xauth: (argv):1:  bad "add" command line
    Starting the gnome panel

    pubuntu@pubuntu:~$
    pubuntu@pubuntu:~$
    pubuntu@pubuntu:~$ df
    Filesystem           1K-blocks      Used Available Use% Mounted on
    /dev/cobd0             3527040   2938988    410664  88% /
    /dev                    119640       244    119396   1% /dev
    none                    119640         0    119640   0% /dev/shm
    none                    119640        76    119564   1% /var/run
    none                    119640         0    119640   0% /var/lock
    none                    119640         0    119640   0% /lib/init/rw
    cofs0                204796588  20404576 184392012  10% /usr/local/pubuntu
    df: `/tmp/pubuntu': Input/output error
    pubuntu@pubuntu:~$ cd /tmp
    pubuntu@pubuntu:/tmp$ ls
    ls: cannot access pubuntu: Input/output error
    pubuntu  pubuntu.automounts

    pubuntu@pubuntu:/tmp$ ls -l
    ls: cannot access pubuntu: Input/output error
    total 0
    d????????? ? ?    ?    ?                ? pubuntu
    -rw-r-r- 1 root root 0 2011-10-18 05:58 pubuntu.automounts

     
  • bob_wh
    bob_wh
    2011-10-19

    It looks like cofs0 was not mounted properly.  Have you tried this more than once? What does your /etc/fstab file look like?

    Since this is the first time being reported it may be something on your system that is different than expected.  How much free memory do you have before you start Pubuntu?

    This is what I get on my system for df and fstab:
    pubuntu@pubuntu:~$ df
    Filesystem           1K-blocks      Used Available Use% Mounted on
    /dev/cobd0             5161536   3149036   1752996  65% /
    /dev                    119640       244    119396   1% /dev
    none                    119640        24    119616   1% /dev/shm
    none                    119640        76    119564   1% /var/run
    none                    119640         0    119640   0% /var/lock
    none                    119640         0    119640   0% /lib/init/rw
    cofs0                 34352608  22650256  11702352  66% /usr/local/pubuntu
    cofs1                 41980648  27239524  14741124  65% /tmp/pubuntu
    cofs2                 41980648  27239524  14741124  65% /media/cofs2
    pubuntu@pubuntu:~$ cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'vol_id -uuid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults           0   0

    # fix for udev on ubuntu 10.4, BW
    dev /dev tmpfs rw 0 0

    # Colinux block device mount points

    # <file system> <mount point>   <type>  <options>   <dump>  <pass>
    /dev/cobd0 / ext3 relatime,errors=remount-ro 0      1
    #/dev/cobdX /path           ext3   relatime,errors=remount-ro 0      0
    # Windows mount points

    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    cofs0 /usr/local/pubuntu cofs user,dmask=0777,fmask=0666 0   0
    #cofsX /path/mount/point cofs user,dmask=0777,fmask=0666 0   0

    #Entry for cdrom
    /dev/cdrom           /media/cdrom              udf,iso9660 user,noauto,exec,utf8

    -Bob

     
  • Kim Hyundon
    Kim Hyundon
    2011-10-19

    I tried it many, many times….

    Actually I used Tres version.
    But when I changed my notebook, It did not work properly, the same reason above.
    So I visisted this site, and I knew new version released.
    I tried to install new version, but I got the same error. -_-;;;

    My notebook has 4G memory, and 500G HDD( C:  220G, D: 260G).
    Before starting pubuntu, It had 3G free memory.

    I think it's problem of cofs1.
    What is the correct mapping of cofs1, It should be mounted D: dirve?

    Hmm. Or problem of large HDD ?

     
  • bob_wh
    bob_wh
    2011-10-19

    Is your "temp" environment variable defiined to point to a existing directory.  If you look in the /src of the Pubuntu source tree you will find the source in the autoit directory.  It defines the directories needed as shown below:

    $portable_ubuntu_directory = @ScriptDir
    $bin_directory = $portable_ubuntu_directory & '\bin'
    $colinux_directory = $portable_ubuntu_directory & '\colinux'
    $cygwin_directory = $portable_ubuntu_directory & '\cygwin'
    $pulseaudio_directory = $portable_ubuntu_directory & '\pulseaudio'
    $configuration_directory = $portable_ubuntu_directory & '\config'
    $images_directory = $portable_ubuntu_directory & '\images'
    $media_directory = $portable_ubuntu_directory & '\media'
    $temp_directory = EnvGet('temp')


    FileWriteLine($colinux_configuration_file, 'kernel=vmlinux')
    FileWriteLine($colinux_configuration_file, 'ro')
    FileWriteLine($colinux_configuration_file, 'initrd=initrd.gz')
    FileWriteLine($colinux_configuration_file, 'setcobd=async')
    FileWriteLine($colinux_configuration_file, 'cobd0="' & $images_directory & '\rootfs.img"')
    FileWriteLine($colinux_configuration_file, 'cofs0="' & $portable_ubuntu_directory & '"')
    FileWriteLine($colinux_configuration_file, 'cofs1="' & $temp_directory & '"')
    FileWriteLine($colinux_configuration_file, 'root=/dev/cobd0')

    So cofs1 is dependent on the environment variable "temp" for your process.

    if you do a set command (no argument) at the command prompt you will display the environment variable definitions for your process.

    in my case it points to the \documents and setting\&lt;userAccount>\local setting\temp directory which happens to be on the c drive.

    It looks like you may have a non-standard configuration. This should have been apparent when the TRES version had the same problem.  There were no changes in this area for version 4.

    if you have "temp" pointing to a valid directory the it may be something related to accessing the directory in question.

    Are you running a version of windows other than XP?  If so it many be related to the version of windows.  Version 4 was tested on XP only as that all I have on my system.

    -Bob

     
  • Kim Hyundon
    Kim Hyundon
    2011-10-21

    Thank you Bob,
    finally I found the reason of the problem…!!!!

    It was language problem…
    I made my account name of  XP in my country language. So temp directory couldn't be recognized…

    Thank you for your help~~