Thanks, Alex.

Yes, I had the 1.3 headers in /usr/local and it was causing the problems.  After going through that I ran into a few issues and it turned out that in 1.3 I had the Data directories automatically building and installing but in the 339 version I was not getting any of the Data directories to build or install hence I was linking against the old versions.  I didn't see anything in the config stuff that turns that on/off?  I just copied the pieces from the 1.3 Makefile over and now it is building fine.

-Mike

On Jul 25, 2007, at 6:03 AM, Alex Fabijanic wrote:


On 7/24/07, mbonnette <mbonnette@mac.com> wrote:
Hi,

In the 1.3 branch whenever I run the Binder I was getting an IO error
right after sample.db is created.  I tried switching over to the main

I don't know what the reason for IO error might be, I have never encountered it. What platform are you on?

trunk and now I can't get the samples to compile.  I'm getting issues
like:

        class Poco::Data::AbstractBinder::Direction has not been declared.

Is it possible that you are mixing the release archive code with the SVN one? Check your POCO_BASE and make sure it points to the proper location.

If you look into the trunk AbstractBinder.h, you'll see that there is Direction enum declared in there:

http://poco.svn.sourceforge.net/viewvc/poco/poco/trunk/Data/include/Poco/Data/AbstractBinder.h?revision=331&view=markup

So, it must be that you are including some other header.

Alex