Document that PMD 5.1.0 requires Java 6

2014-02-21
2014-04-08
  • Hi

    I'm a committer on the Maven project where I do some work on Maven PMD Plugin. We have just discovered that PMD 5.1.0 requires Java 6. The move seems to be intentional, but isn't documented on your web site. The building instructions at http://pmd.sourceforge.net/pmd-5.1.0/compiling.html says you need Java 5 or newer, and the release notes for 5.1.0 does not mention the upgrade to require Java 6.

    It would be great if you could update the web site accordingly.

    The issue where we track this at our end is here:
    http://jira.codehaus.org/browse/MPMD-176

     
  • Andreas Dangel
    Andreas Dangel
    2014-04-08

    Thanks for letting us know. The next version will have the documentation updated.