Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Can't compile 0.59.1

Anonymous
2013-04-22
2013-07-24

  • Anonymous
    2013-04-22

    Bonjour,

    I can't compile (qmake, make) the last version, I get 100+ errors like:

    In file included from /usr/include/qt4/QtCore/QtCore:53:0,
    from /usr/include/qt4/QtGui/QtGui:3,
    from src/wordcountengine.h:5,
    from src/maintextdocument.h:9,
    from src/slimfindreplace.h:6,
    from moc_slimfindreplace.cpp:10:
    /usr/include/qt4/QtCore/qtconcurrentfilter.h: In function ‘QtConcurrent::ThreadEngineStarter<void> QtConcurrent::filterInternal(Sequence&, KeepFunctor, ReduceFunctor)’:
    /usr/include/qt4/QtCore/qtconcurrentfilter.h:108:47: warning: typedef ‘Iterator’ locally defined but not used [-Wunused-local-typedefs]
    typedef typename Sequence::const_iterator Iterator;

    Using QT 4.8.4 in Archlinux (having also qt5 installed).
    Same thing in QtCreator.

    Merci, ++ !

     

  • Anonymous
    2013-04-22

    Actually, sorry. It was a stupid mistake from my side :)
    Everything's allright.
    ++

     


Anonymous


Cancel   Add attachments