pango_layout_get_baseline was not introduced until 1.22 (

Centos, being an "enterprise" distro (based of RHEL), does not have up-to-date versions of fast changing libraries. I suspect your options are:
1) Try an older version of plplot
2) Use a more "cutting edge" distro.

On 11 September 2013 21:25, Michael Urban <> wrote:
There seems to be some linking issue with Pango that I cannot fathom.

The result of 'make':

 Linking C executable plserver
 ../../src/ undefined reference to `pango_layout_get_baseline'
 collect2: ld returned 1 exit status
 make[2]: *** [bindings/tk/plserver] Error 1
 make[1]: *** [bindings/tk/CMakeFiles/plserver.dir/all] Error 2
 make: *** [all] Error 2
% rpm --query pango
% rpm --query cairo

This is CentOS 5.5.


How ServiceNow helps IT people transform IT departments:
1. Consolidate legacy IT systems to a single system of record for IT
2. Standardize and globalize service processes across IT
3. Implement zero-touch automation to replace manual, redundant tasks
Plplot-general mailing list