I tried to install plplot using the directions given at http://www.miscdebris.net/plplot_wiki/index.php?title=Building_PLplot

The installation gave a number of warnings (listed at the end of this email). One of the warnings is:

-- WARNING: pango, pangoft2, or lasi not found with pkg-config.
   Setting PLD_psttf to OFF.  Please install all of these packages
   and/or set the environment variable PKG_CONFIG_PATH appropriately.


Any help getting rid of  this warning would be most helpful.

I am on the Linux system  "Linux version 2.6.18-238.19.1.el5 (mockbuild@hs20-bc2-4.build.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-50)) #1 SMP " and information on the internet seems to suggest that pango is integrated into Linux. But I have no idea where to find these packages.

I want to use plplot for generating png/postscript/pdf within C programs and I do not want a GUI or interactive platform.

Many thanks!

Divakar

-----------------------------

-- WARNING: The Numeric extension for Python is deprecated.  Support for
Numeric will be dropped in a future PLplot release. Please switch to numpy
by installing that Python extension and/or specifying HAVE_NUMPY ON and
FORCE_NUMERIC OFF.
-- WARNING: Disabling Python. If you really wish to enable the deprecated
Numeric support set FORCE_NUMERIC ON.
-- WARNING: octave not found. Disabling octave bindings
-- WARNING: qhull library not found.  Setting PL_HAVE_QHULL to OFF.
-- WARNING: libltdl library not found. Setting ENABLE_DYNDRIVERS OFF.
   Please install that library and/or set the environment variables
   CMAKE_INCLUDE_PATH and CMAKE_LIBRARY_PATH appropriately.
-- WARNING: pango, pangoft2, or lasi not found with pkg-config.
   Setting PLD_psttf to OFF.  Please install all of these packages
   and/or set the environment variable PKG_CONFIG_PATH appropriately.
-- WARNING: ENABLE_DYNDRIVERS is OFF so force PLD_extqt to be OFF
-- WARNING: Qt4 development environment not found so disabling all qt devices.
-- WARNING: PLD_extqt is OFF so setting ENABLE_qt to OFF.
-- WARNING: ENABLE_python is OFF so setting ENABLE_pyqt4 to OFF.
-- WARNING: wxWidgets not found so setting all wxwidgets devices to OFF.
-- WARNING: PLD_wxwidgets is OFF so setting ENABLE_wxwidgets to OFF.
-- WARNING:ocamlc not found. Disabling ocaml bindings
-- validate target will be available to check for syntax issues in the PLplot DocBook documentation using /usr/bin/onsgmls.
-- WARNING: Perl modules XML::Parser and/or XML::DOM not available
   so cannot check that swig_documentation.i is up to date.