(sorry if its the second and same mail you've received...)

Hi arjen (and you all plplot-general if this mail succeeds in reaching you...)!

well, I can now be more precised on the issus I encountered for porting PDL::Graphics::PLplot
on cygwin.

Here is my environment:

windaube XP  [french joke, like winstinks XP ; ) ] 5.1 build 2600 service pack2

cygwin dll 1.5.18 / shared id cygwin 1S4

perl v5.8.7 build for cygwin

PDL 2.4.2

plplot5.5.3

So, there are strange things during the install of PDL:
    - at perl Makefile.PL
             it can't find libplplot.dll : actually, libplplot.dll.a exists so, it finally works if
                                                                    - I "cp libplplot.dll.a libplplot.dll
                                                              or  - I modify Makefile.PL in /Graphics/PLplot : my $libname = "libplplotd.dll.a" instead of
                                                                                                                                           my $libname = "libplplotd.dll".config("so")
   - finally, it (seems to) work but, at the end of "make":
            it can't find /blib/script/pdl : actually, "pdl.exe" exists, so I "cp PDL.exe PDL" ... and it works (?)

  - make install : all (seems to be) is ok

 - perldl inline command works:
     perldl> $x = sequence 3,4
     perldl> set $x, 2,1,99
     perldl> p $x
     [
      [ 0  1  2]
      [ 3  4 99]
      [ 6  7  8]
      [ 9 10 11]
     ]
    (from http://www.us025.ird.fr/article.php3?id_article=17)

Now, the problem is:
 perl -v "use PDL::Graphics::PLplot;"
 can't load '/usr/lib/perl5/site_perl/5.8/cygwin/auto/PDL/Graphics/PLplot/PLplot.dll' for module PDL/Graphics/PLplot:
no such file or directory in Dynaloader.pm line 230

(line 230 of Dynaloader:; my $libref = dl_load_file( [...] )     )

But /usr/lib/perl5/site_perl/5.8/cygwin/auto/PDL/Graphics/PLplot/PLplot.dll exists (libPLplot.dll.a too) and is non void!!!

I didn't find any similar situation neither on the web nor in forums and i can't remember the number of (re)installation of
the whole config (including cygwin)   : (

any suggestions will be welcomed as the first day of spring after a long and cold winter : p,

regards,

bruno


--
____________________________________________________
Dr. Bruno Picard
Dép. Traitement de la Mesure et Segment Sol
(Data Analysis and Ground Processing Unit)  
CLS
Dir.  Océanographie Spatiale
8-10 rue Hermès, 31520 Ramonville Saint Agne, France

Tél: (+33)5.61.39.37.37, Fax: (+33)5.61.39.37.82
Mél: bruno.picard@cls.fr
Toile : http://julie-et-bruno.9online.fr/nono/cadrenono.html
____________________________________________________