Problems compiling program

RC
2009-03-28
2013-03-15
  • RC
    RC
    2009-03-28

    Hi,
    I tried to compile one of the example files in plplot v5.9.0 (Ubuntu 8.10)  using:
    /opt/intel/fce/10.1.015/bin/ifort  x01f.f90 -o x01f -Wl,-rpath -Wl,/usr/local/lib:/usr/lib `PKG_CONFIG_PATH=/usr/local/lib/pkgconfig pkg-config --cflags --libs plplotd-f95`
    x01f.f90(54): (col. 9) remark: LOOP WAS VECTORIZED.
    x01f.f90(54): (col. 9) remark: LOOP WAS VECTORIZED.
    x01f.f90(66): (col. 9) remark: LOOP WAS VECTORIZED.
    x01f.f90(66): (col. 9) remark: LOOP WAS VECTORIZED.
    x01f.f90(68): (col. 9) remark: PARTIAL LOOP WAS VECTORIZED.
    x01f.f90(68): (col. 9) remark: PARTIAL LOOP WAS VECTORIZED.
    x01f.f90(69): (col. 9) remark: PARTIAL LOOP WAS VECTORIZED.
    x01f.f90(69): (col. 9) remark: PARTIAL LOOP WAS VECTORIZED.
    ld: warning: libltdl.so.3, needed by /usr/local/lib/libplplotf95d.so, not found (try using -rpath or -rpath-link)

    I have libltdl.so.7 in /usr/lib.  I had some problems when trying to compile plplot earlier, so I downloaded plplot using the Synaptic package manager, which does not have libltdl.so.3 available. Is there a way to get my installed version to work, or will I have to try to compile it locally?
    Thanks,
    Recif

     
    • Werner Smekal
      Werner Smekal
      2009-04-08

      You could try to make a symlink from libltdl.so.7 to libltdl.so.3. This often works and since the PLplot use of this interface is only basic, this should work. Still it is a hack and maybe it's better to compile PLplot yourself. Version 5.9.2 has a lot of changes and bug fixes included. I'll send your report to the list, since it might be important for the debian packager.

      Regards,
      Werner