Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#36 Problem buiding plplot 5.6.1 with LASi 1.0.4

closed
nobody
None
5
2006-06-06
2006-06-06
Anonymous
No

...
c++ -DHAVE_CONFIG_H -I. -I. -I.. -I../include
-I../include -I../include
-I/usr/local/include/freetype2 -I../libltdl
-I/usr/local/include -I/usr/local/include/glib-2.0
-I/usr/local/lib/glib-2.0/include -I/usr/local/includei
-I/usr/X11R6/include/pango-1.0 -I/usr/X11R6/include
-I/usr/local/include/freetype2 -I/usr/local/include -Os
-march=nocona -fconserve-space -MT psttf_la-psttf.lo
-MD -MP -MF .deps/psttf_la-psttf.Tpo -c psttf.cc -fPIC
-DPIC -o .libs/psttf_la-psttf.o
psttf.cc: In function `void plD_tidy_psttf(PLStream*)':
psttf.cc:604: error: no matching function for call to
`LASi::PostscriptDocument::write(std::ostream&, int&,
int&, int&, int&)'
/usr/local/include/LASi.h:125: note: candidates are:
void LASi::PostscriptDocument::write(std::ostream&)
psttf.cc:609: error: no matching function for call to
`LASi::PostscriptDocument::write(std::ofstream&, int&,
int&, int&, int&)'
/usr/local/include/LASi.h:125: note: candidates are:
void LASi::PostscriptDocument::write(std::ostream&)
*** Error code 1

Discussion

  • Alan W. Irwin
    Alan W. Irwin
    2006-06-06

    Logged In: YES
    user_id=15737

    As stated in the release notes, you must use lasi-1.0.5
    from http://www.unifont.org/lasi/

     
  • Alan W. Irwin
    Alan W. Irwin
    2006-06-06

    • status: open --> closed