Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#117 PLplot 5.9.8: Compilation error with deprecated

closed-fixed
nobody
None
5
2011-09-13
2011-09-13
No

I did found comilation errors in PLPlot 5.9.8.
This occurs with new things moved in deprecated section.
Joind is the output or command (with configuration options)
and 2 patches I made in order to compile but are certainly not correct for evrey case. they only show where I found the errors.
If I activate the CMAKE Boolean parameter PL_DEPRECATED it does not compile too but sooner in wrappers.

Discussion

  • Tar with compile log and patches

     
  • Andrew Ross
    Andrew Ross
    2011-09-13

    Compiling with PL_DEPRECATED was broken as a few old functions were removed from the core library in the last release, but not from all the bindings. I have now fixed that.

    The plmeta driver (and plrender) have been unmaintained since plplot 5.8.0 and both are disabled by default. Do you still need to use these? If not you should strongly consider alternatives. If you really need them then there are 2 options

    1) Stick with an older version of plplot.
    2) Help to fix and maintain them.

    The last time they were tested (pre 5.8.0) there were a number of issues with strings, aspect ratio changes and fonts. The situation is likely to have deteriorated since then as your bug report shows. It will take more than your quick fixes to the compilation to make them work properly.

     
  • Andrew Ross
    Andrew Ross
    2011-09-13

    Based on your patches I have committed changes to svn so that plrender will compile again without needing the -DPL_DEPRECATED=ON option. This is not tested, and my previous comments on plrender being unsupported and having problems still stand.

     
  • Andrew Ross
    Andrew Ross
    2011-09-13

    • status: open --> open-fixed
     
  • Andrew Ross
    Andrew Ross
    2011-09-13

    • status: open-fixed --> closed-fixed