Buildout for trunk

Developers
2010-06-16
2013-04-25
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    Does anyone have a simple buildout to use plomino trunk. I'm currently using universal installer for plone 3.3.5 with Plomino in the eggs section.

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    I added your suggestions and now running buildout returns:
    "mr.developer: The source definition of 'zope-directory' needs at least the repository kind and URL."

    My zope-directory in my buildout.cfg points to my instance dir. I commented out the line and it now says:
    mr.developer: Unknown repository type 'http://dist.plone.org' for source 'find-links'

    Sorry for the 20 questions but I've never user mr.developer before.

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    Hi Eric,

    Firstly, thanx a lot for all your help.

    I followed your instructions but then I get the I get the error below when I load the CMFPlomino profile (note that I don't get Plomino in my quickinstaller). I added collective.js.jquery to by buildout eggs but I still the get same problem.

    2010-06-16 12:51:24 ERROR GenericSetup Unknown step in dependency chain: u'profile-collective.js.jquery:default'
    2010-06-16 12:51:24 ERROR Zope.SiteErrorLog 1276685484.80.526477912912 http://localhost:8080/manage_addProduct/CMFPlone/addPloneSite
    Traceback (innermost last):
      Module ZPublisher.Publish, line 119, in publish
      Module ZPublisher.mapply, line 88, in mapply
      Module ZPublisher.Publish, line 42, in call_object
      Module Products.CMFPlone.factory, line 88, in addPloneSite
      Module Products.GenericSetup.tool, line 390, in runAllImportStepsFromProfile
       - __traceback_info__: profile-Products.CMFPlomino:default
      Module Products.GenericSetup.tool, line 1152, in _runImportStepsFromContext
      Module Products.GenericSetup.tool, line 1134, in getProfileDependencyChain
      Module Products.GenericSetup.tool, line 1132, in getProfileDependencyChain
      Module Products.GenericSetup.tool, line 910, in getDependenciesForProfile
    KeyError: u'profile-collective.js.jquery:default'

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    Hang on, I didn't add collective.js.jsquery to the zcml. The saga continues …

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    I rebuit and now I get the following when importing the CMFPlomino profile:

    2010-06-16 13:34:13 INFO Zope Ready to handle requests
    2010-06-16 13:35:06 ERROR GenericSetup Unknown step in dependency chain: u'profile-collective.js.jqueryui:withjqtoolsplone3'
    2010-06-16 13:35:06 ERROR Zope.SiteErrorLog 1276688106.340.250254695948 http://localhost:8080/test2/portal_setup/manage_importAllSteps
    Traceback (innermost last):
      Module ZPublisher.Publish, line 119, in publish
      Module ZPublisher.mapply, line 88, in mapply
      Module ZPublisher.Publish, line 42, in call_object
      Module Products.GenericSetup.tool, line 600, in manage_importAllSteps
      Module Products.GenericSetup.tool, line 390, in runAllImportStepsFromProfile
       - __traceback_info__: profile-Products.CMFPlomino:default
      Module Products.GenericSetup.tool, line 1152, in _runImportStepsFromContext
      Module Products.GenericSetup.tool, line 1134, in getProfileDependencyChain
      Module Products.GenericSetup.tool, line 1132, in getProfileDependencyChain
      Module Products.GenericSetup.tool, line 910, in getDependenci

     
  • Eric Brehault
    Eric Brehault
    2010-06-16

    oops, right, I hadn't committed my last change in setup.py (to declare the required packages)

    svn up your Plomino folder, re-run buildout and re-install Plomino (it should appear in the quick installer now)

    Eric

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    Ok, that start off well. CMFPlomino now appears in the the quickinstalled and when I add a row I don't get the error above. But when I hit save it still spins endlessly.

     
  • Jean Jordaan
    Jean Jordaan
    2010-06-16

    Not squid?

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    I seem to have version problems so I created a complete new instance, changed the buildout, pulled in the src's. Now my buildout returns the following, but the save row still hangs and not errors in the terminal.

    Products.TinyMCE = 1.1rc12
    #Required by:
    #Plomino 1.6.2
    #collective.js.jqueryui 1.7.2.7
    collective.js.jquery = 1.3.2.1
    #Required by:
    #Plomino 1.6.2
    plone.app.jquerytools = 1.1b5

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-16

    Squid? No, I'm on a local instance.

     
  • Eric Brehault
    Eric Brehault
    2010-06-16

    when you say "the save row still hangs", you mean a row in a datagrid field ?
    if so, maybe you have some issues with the datagrid settings (associated form and so on)

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-17

    In a new local instance, I created a site, created a database and imported the datagrid sample db. I select Order, Add Row, enter values and hit save and it hangs.

     
  • Could you access it through http://hathawaymix.org/Software/TCPWatch ? That would show exactly what it's waiting for.
    Are you logging everything?

     
  • Eric Brehault
    Eric Brehault
    2010-06-17

    Hello,

    my colleague had just reproduced the same bug
    it sounds like a jquery issue
    we are working on it

    Eric

     
  • Eric Brehault
    Eric Brehault
    2010-06-17

    Ok, fixed :)
    check out last svn version

    when you have run your buildout, you have picked plone.app.jquerytools 1.1b5, but when we have developed the datagrid field, plone.app.jquerytools was 1.0b17

    we changed the way we access data from the associated form, to be compliant with plone.app.jquerytools 1.1b5, and now it works

    Eric

     
  • Mike Metcalfe
    Mike Metcalfe
    2010-06-18

    Checked out the latest trunk and it works! Thanx Eric.

     
  • Jean Jordaan
    Jean Jordaan
    2010-06-18

    Yay :-)