#11 bug in emphasize with 4 apostrophes

closed-fixed
5
2008-01-04
2007-12-29
Anonymous
No

If you render the text ''''emphasized'''' with the WikiModel.render(String) method you get an italic and bold word "emphasize", i.e. the last letter is missing.

Discussion

  • Axel C. Kramer
    Axel C. Kramer
    2007-12-29

    • status: open --> pending-fixed
     
  • Axel C. Kramer
    Axel C. Kramer
    2007-12-29

    Logged In: YES
    user_id=1143825
    Originator: NO

    This bug should now be fixed in the SVN source repository.

    some''''emphasized''''text"

    now renders to:

    \n<p>some<b>&#39;emphasized</b>&#39;text</p>

     
  • Axel C. Kramer
    Axel C. Kramer
    2007-12-29

    • assigned_to: nobody --> axelcl
    • labels: --> Wiki_to_HTML
     
  • Stefan Wachter
    Stefan Wachter
    2008-01-02

    • status: pending-fixed --> open-fixed
     
  • Stefan Wachter
    Stefan Wachter
    2008-01-02

    Logged In: YES
    user_id=588968
    Originator: NO

    I thought that text surrounded by 4 apostrophes should be italic and bold. It seams that 4 apostrophes are now treated like 3 apostrophes.

     
  • Axel C. Kramer
    Axel C. Kramer
    2008-01-02

    • status: open-fixed --> pending-fixed
     
  • Stefan Wachter
    Stefan Wachter
    2008-01-03

    • status: pending-fixed --> open-fixed
     
  • Stefan Wachter
    Stefan Wachter
    2008-01-03

    Logged In: YES
    user_id=588968
    Originator: NO

    It seems that there are different definitions at Wikipedia!

    With the current solution were a bold word is enclosed by apostrophes the preceding apostroph is bold whereas the following isn't. I think that this is not what most be people would like to have.

    Maybe it would make sense to have both 4 and 5 apostrophes being bold and italic? Anyway, the issue can be closed.

     
  • Axel C. Kramer
    Axel C. Kramer
    2008-01-04

    • status: open-fixed --> closed-fixed