#1 Deprecated constructions in WikiEditorPlugin

closed
nobody
None
5
2005-10-20
2005-03-29
Stas Fomin
No

I download version 1.1.5 of Plog4u, but this version
failed to work both with global and local MediaWiki sites.
("HTTP Method failed").
I start to debug the plugin, but I discovered, that my
Eclipse 3.0.1. (with org.eclipse.osgi_3.0.1) ignores
WikiEditorPlugin with deprecated constructor
---
public WikiEditorPlugin(IPluginDescriptor descriptor) {
---
(constructor not called during plugin activation, and all
other plugin actions unavailable - classes not found)

When I redefine constructor as
---
public WikiPlugin() {
---
then the constructor is called, but many other problems
appear - some exceptions in deprecated calls
IPluginDescriptor pluginDescriptor =
extension.getDeclaringPluginDescriptor();

Then I try to fix all deprecated calls, I encounter that
the line in constructor
---
manager = ConfigurationManager.getInstance();
---
uses Plugin.bundle, which now initialized only in start()
function....

So I stop my attempts and wrote this bug (I am
completely new in Eclipse and Eclipse plugins writing).

Please, make the plugin code debugeable under Eclipse
3.0.1.

Sincerely, Stas Fomin.

Discussion

  • Axel C. Kramer
    Axel C. Kramer
    2005-04-02

    Logged In: YES
    user_id=1143825

    I'm not sure if I understand all of your steps above.
    Do you have a public MediaWiki installation, which I can test.
    Please EMail directly to axelclk [at] gmail [dot] com, so
    that we can solve you problems.

    (BTW: The wiki plugin depends on the
    net.sourceforge.phpeclipse.webbrowser; did you install this
    plugin in your test environment?)

     
  • Axel C. Kramer
    Axel C. Kramer
    2005-10-20

    • status: open --> closed