need urgent help , getting error: PLS-00488: 'JSON' must be a type

2014-08-14
2014-08-18
  • Nagesh Patil
    Nagesh Patil
    2014-08-14

    Hi,

    I have successfully install the install.sql file . I can see JSON pkg in SQL Developer, but when I execute example 1 given in example directory, I get this error: PLS-00488: 'JSON' must be a type.

    plz help me solve this issue.

    Thanks in Advance.

    Nagesh

     
  • Herb Swift
    Herb Swift
    2014-08-14

    The install script supplied by Jonas should have compiled not only the packages, but also the related UDF types, such as JSON, JSON_LIST, JSON_VALUE, and JSON_VALUE_ARRAY. Do you see these listed under Types in SQL Developer?

     
  • Nagesh Patil
    Nagesh Patil
    2014-08-18

    Thanks Herb Swift,

    Actually I have executed install.sql with different user login, so that it was not accessible to me. Now I install with my DB user and it works fine now..

    Thanks for your help.