PLE CMS / News: Recent posts

Security Vulnerabilities and the Road to 1.0

After a 7 year hiatus, I decided to take a quick look at this project. It appears that there are still a small, but regular number of downloads of the project. Please be aware that this project currently contains multiple security vulnerabilities including, but not limited to http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0394

If you are currently using this project, please use it on very isolated servers, with as much locked down permission-wise as possible.... read more

Posted by Nathan 2011-09-03

Beta 4.2 of PLE CMS v1.0 released

This includes a few minor fixes, including a fix for the installation script errors on certain mysql versions.

IMPORTANT PHP 5:
Note, that on Windows platforms (I think other platforms are ok--needs to be verified) email validation will *not* work on PHP 5 -- emails for signing up students will not be sent. (a fix is in the investigation stage). Setting VALIDATE_EMAILS = false *must* be in configuration.php if using this with PHP 5.0 (on windows platforms. other platforms?)

Posted by Nathan 2004-08-24

Bug Alert

BUG ALERT: For beta 4, The installation script may fail on certain versions of mysql. To fix this, you may grab the updated ple_main/install.php from CVS. (A new release that includes this fix will be posted shortly)

Posted by Nathan 2004-07-25