I have compiled the code (from Chapter 5 in the tutorial) successfully. However, it does not say in the tutorial how to include it in worldfile so the simulation can run that control code. I checked the "simple.cfg" file and noticed it uses 'cntrl "wander"' to control the robot for simulation. And I did the same thing in my configuration file and included 'ctrl "bigbob"' but when I run it I get the aforementioned error.


As far as I understand, right now player/stage does not know the path of "bigbob" location, hence throwing the error. So my question is how would I include "bigbob" in the player/stage path so that it would know where to look for? Generally speaking, if I were to write a custom control code for a robot, how would player/stage call it ?

Any suggestion would be greatly appreciated.

Achyut



On Fri, Jul 29, 2011 at 8:45 PM, Arkapravo Bhaumik <arkapravobhaumik@gmail.com> wrote:
Hi

I am not completely sure, but I think it is an issue of mismatch - Jennifer's tutorials are for Stage 3.2.X while you are using Stage 4.0.0, which is a more advanced version of Stage. You will have to rewrite some of the code to make it work in Stage 4.0.0

That is all I can say, I do not know much about Stage 4.X.X, still happy with Stage 3.2.2

Regards

Arkapravo


On 30 July 2011 00:14, Achyut Shrestha <shresthachyut@gmail.com> wrote:
Hi,

I am new to Player/Stage and I am following Jennifer Owen's tutorial to learn it. I successfully complied the "bigbob.cc" for controlling a robot and added "bigbob" in worldfie. However when I run the command "player empty.cfg", I get the following error:

Libtool error: file not found. Can't open your plugin controller. Quitting
err: Failed to open "bigbob". Check that it can be found by searching the directories in your STAGEPATH environment variable, or the current directory if STAGEPATH is not set.]
 (/builddir/build/BUILD/Stage-4.0.0-src/libstage/model_load.cc LoadControllerModule)
libtool error #2

I echoed STAGEPATH and it was blank so I exported to include "/usr/lib" (as suggested in one of the postings) however it still gives me the same error. I was able to run "simple.cfg" without any problem even before I exported STAGEPATH. What am I missing? Please help.

Achyut


------------------------------------------------------------------------------
Got Input?   Slashdot Needs You.
Take our quick survey online.  Come on, we don't ask for help often.
Plus, you'll get a chance to win $100 to spend on ThinkGeek.
http://p.sf.net/sfu/slashdot-survey
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users