Hey again!

Could anybody give me some tips? Basically, it seems that a planner is making the robots behave differently in the latest versions of player and stage on my machine(3.1.0-svn and stage 4.1.1) whereas it worked perfectly in those versions I used to use: Player 2.1.3 and Stage 2.1.1.

Could that be possible? Or must have been something else what changed the behaviour?

Kind regards,


2013/6/15 Iņigo Odriozola <odri.1988@gmail.com>
Hey Everyone!

I would need some tips here. The thing is that we managed to create a plugin for an edited version of a well-known planning algorithm a couple years ago. We made various tests and everything worked perfectly. We used Player 2.1.3 eta Stage 2.1.1 versions for making these tests.

Now, we have upgraded to player 3.1.0-svn and stage 4.1.1 versions and for those, we optimized and made little changes in the pluggin, such as using ThreadedDriver in stead of Driver and so on. The problem is that the robot behaves in a strange way now. If we give the same paths, that is the same starting and goal points, as in the previous project years ago to the robot, it will make unefficient moves, turns, it will behave differently.

The question is: could the changing of player and stage versions be the reason of this behaviour? What could have happened? Which could be the reason of this behaviour change in the robot?

Many thanks in advance!