Did you install different versions of Player?

I remember this fault to happen when switching from Player-2.1.2 to 3.0.

To fix it will have to recompile Stage-3.2.2.
 
To check the player version with which player was compiled go to Stage directory and type > cmake .

Best Regards,

  Robert

-------------------------------------------------
Roberto Guzman
Departamento de Ingenieria
-------------------------------------------------
Robotnik Automation, SLL
C/Berni y Catala, 53 bajo
46019 - VALENCIA - SPAIN
-------------------------------------------------
Tel:       +34 963383835
Fax:      +34 963383580
E-mail:  rguzman@robotnik.es
Internet:  http://www.robotnik.es
-------------------------------------------------

2010/8/20 gtg056s <jacob.yoonsuk@gmail.com>

Hey,

So I finally decided to update my Player/Stage along with the OS system up
to date, but a problem occurs when I run Player that I can't recognize from
anywhere in this forum.

It seems that Stage is running fine. I have no problem running the world
file on Stage, but when I run the cfg file on Player, the following error
occurs.

I'm running Player-3.0.2 and Stage-3.2.2 on Ubuntu-10.04.

Player: /player/libplayercore/message.cc:694: QueuePointer&
QueuePointer::operator=(const QueuePointer&): Assertion 'rhs.Lock' failed.
Aborted


Can anyone help me resolve this problem? Any help and support will be
greatly appreciated.

Jacob
--
View this message in context: http://old.nabble.com/Player-3.0.2-on-Ubuntu-10.04-tp29489259p29489259.html
Sent from the playerstage-users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
This SF.net email is sponsored by

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users