Hi,

I've just (as in, 15 minutes ago) installed Stage 3.1.0 on Ubuntu 9.0.4. These are the packages I needed to install (having, of course, already installed player):

sudo apt-get install cmake
sudo apt-get install libfltk1.1-dev libfltk1.1
sudo apt-get install libglu1-mesa-dev

After that, both cmake and make ran successfully.

Hope it helps!