on the gumstix I run ./player create.cfg which says

# ./player create.cfg

* Part of the Player/Stage/Gazebo Project [http://playerstage.sourceforge.net].
* Copyright (C) 2000 - 2006 Brian Gerkey, Richard Vaughan, Andrew Howard,
* Nate Koenig, and contributors. Released under the GNU General Public License.
* Player comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
* are welcome to redistribute it under certain conditions; see COPYING
* for details.

Opening connection to Roomba on /dev/ttyS2...Done.
Listening on ports: 6665


Then on the build system I run ./intro create.xml and it says

john@john-desktop:~/roboticsprimer-0.1/exercises/01_introduction/gumstix$ ./intro client.xml
Loading config file[client.xml]
Trying to connect to [192.168.1.102:6665]
calling connect
done

then over on the gumstix it says

accepted client 0 on port 6665, fd 9
./player: can't resolve symbol 'xdrmem_create'

and player terminates

and on build system it says

playerc error   : recv failed with error [Success]
warning : failed to reconnect
playerc error   : failed to get response
terminate called after throwing an instance of 'PlayerCc::PlayerError'
Aborted (core dumped)
 presumably because player didn't get back to it


Questions
1) What does "./player: can't resolve symbol 'xdrmem_create'" indicate?
2)I had to load a xdr library to compile some part of player, did I load the wrong one?
I have all the shared librarys ldd says player needs in /lib


John Cummins


Need a vacation? Get great deals to amazing places on Yahoo! Travel.