Hi guys:

I am quite new to Player (V. 1.6.5), so i have been trying some programs but regarding to use the LMS-200 laser range finder it has been failing to connect. I wonder what migth be the problem.

Below you can find the messages displayed by the applications.
My server script is so simple:
driver
(
 name "sicklms200"
  provides ["laser:0"]
   port "/dev/ttyS0"
#    delay 0  #or  35, anyway same result
 rate 38400
  # resolution 25
  # range_res 1
)

And the client application when it runs in the local and/or remote host yields the same results.
(in different computers i have got the same problem). Let me highlight that when establishing the connection (Client/Server) the LMS200 green-light switches to red-light, and i have to manually re-initialize the sensor every time

Hope someone could enlighten me! (BTW the laser sensor password was previously reseted with a windows application )

Thank you and regards,

Martinelo


CLIENT SIDE
user@host ~ $ ./laserobstacleavoid -h 1xx.xx.xxx.xx -p 7777
WARNING: tried to get 'r' access to device 7777:6:0 but got 'e' access.
can't read from laser

SERVER SIDE (whatever it be the port, i get same results)

root@mobility:~/mydir# player -p 7777 lms200.cfg
** Player v1.6 ** [Port 7777] [TCP]

Parsing configuration file "lms200.cfg"
Using device table:
------------------------------------------------------------
0 driver sicklms200 id 7777:laser:0
------------------------------------------------------------
listening on port 7777
** Player [port 7777] client accepted from 1xx.xx.xxx.xxx on socket 7 **
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
warning : timeout
error   : unable to connect to laser
error   : no reply from laser
** Player [port 7777] killing client on socket 7 **


Send instant messages to your online friends http://uk.messenger.yahoo.com