Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

sdrc can't find DSO function

Help
2006-12-15
2013-04-25
  • Richard Layman
    Richard Layman
    2006-12-15

    I've been messing with DSO's and can compile them without a problem, but I can't seem to compile the shader that uses them. I'm using the myfun example in the documentaion and it keeps saying that myfun is not found. I searched the board and found this problem by other people, but it was supposed to be fixed by making it so Pixie would look in the same folder as the shader being compiled, but it still doesn't seem to work. I'm on Linux, if that makes difference.

    Here are the files that I'm using (they are all in the same folder):
    http://www.paradiseva.com/stuff/myfun.tar.gz

    The commande I'm using to compile the shader is
    sdrc myfun.sl

     
    • Okan Arikan
      Okan Arikan
      2006-12-15

         Hi Richard,

         sdrc myfun.sl -I.

         should work. I tried to check this but the c file in the tarball is empty.

         Okan

       
      • Richard Layman
        Richard Layman
        2006-12-15

        Wow, what happened to the c file?! It's empty on my computer too :(
        I fixed it and replaced the file on the server, so just redownload the same file and it should all be there. The funny thing is that I didn't have any problems the first time I compiled it, but I kept getting errors the second time. I ended up taking out the init and cleanup (they weren't being used anyway) and it compiled fine.

        I tried the line that you gave me, but it still gives me the same error. I don't know if this has anything to do with it, but I don't have anything in my Pixie include or lib folders. I don't see how that would effect anything because I've tried to compile Pixie shaders in the myfun folder and it works fine.