Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

uv texture map

Help
2007-01-07
2013-04-25
  • Gabriele Betti
    Gabriele Betti
    2007-01-07

    Hello again,
    I did a test for texture mapping a character , but uv don't match,
    Model was exported from Blender with blender2Pixie script.
    I am using the paintedplastic shader , am I missing some parameter ?
    I could see that there should be a shader around called texmap with this parameters:

    texmap "texmap" "Ka" "Ks" "Kd" "roughness" "specularcolor" "texname" "maporigin"
           "xaxis" "yaxis" "zaxis" "maptype "s1" "t1" "s2" "t2" "s3" "t3" "s4" "t4"
           "Ka" 1.0 "Ks" 0 "Kd" 1.0
           "roughness" 0.25
           "specularcolor" [1 1 1]
           "texname" "name of texture file"
           "maporigin" [0 0 0]
           "xaxis" [1 0 0] "yaxis" [0 1 0] "zaxis" [0 0 1]
           "maptype" 3 (ie. no projection)
           "s1" 0 "t1" 0 "s2" 1 "t2" 0
           "s3" 0 "t3" 1 "s4" 1 "t4" 1
           This shader texture maps a surface. The name of the texture file is given by
           texname. The parameters maporigin, xaxis, yaxis, zaxis, maptype, s1-4 and t1-
           4 are passes directly

    Maybe usefull for testing.
    How could I test uv in Pixie ?
    Thanks.
    Gab-

     
    • rendetto
      rendetto
      2007-01-08

      Hi gabdab,

      Actually blender2pixie.py has some issues to fix. The problem seems to be in the UVcoords exporting cycle. You should edit the script to achieve proper results. Try replacing the statement face.uv[x][1] with 1.0-face.uv[x][1] and it will work.

      I hope that helps ;)

      Cheers,
      rendetto