Newbie trying to compile pixie on Windows XP

froqw
2006-08-03
2013-04-25
  • froqw
    froqw
    2006-08-03

    I got the error message saying "can't open zlibd.lib". Since I didn't have it on my machine, I went ahead change it to "zlib.lib". Compilation's successful, but would that make unpleasant difference? Why does pixie use the debug version of zlib?

     
    • Okan Arikan
      Okan Arikan
      2006-08-03

        the release version should link with zlib.lib. i will check and correct if this is not the case.

        thanks

        Okan

       
    • froqw
      froqw
      2006-08-03

      I can build Pixie now either using "batch build" to choose the configurations, or directly "build solution". BTW, I am using vcnet8.

      But rndr and texmake can not run, and I got the message saying "This application has failed to start because libtiff3.dll was not found. Re-installing the application may fix this problem". Since I am really new to this thing, could you help me figure out what went wrong.

      I follow the compiling instruction: 1. get libtiff, zlib, flex/bison from GnuWin32; 2. dis-select openexr and show projects; 3. Modify the corresponding paths to the "additional include" and "lib" directories for each project, and change zlibd.lib to zlib.lib; 4. Build the solution.

      All the projects are successfully built, but most of them have different byte number than windows distribution binaries. I am wondering if I did something wrong, or used different libs than you did.

      Any advice is appreciated. Thanks.