PIdgin Just installed, won't load

Spam3234
2008-01-17
2013-01-14
  • Spam3234
    Spam3234
    2008-01-17

    I just installed Pidgin on my PC, and when I try to run it, it begins to load and then quits (w/o any warning or error message.)  when I run it on the command line, this is what occurs:

    bills@linux-5di7:~> pidgin
    pidgin: symbol lookup error: pidgin: undefined symbol: g_timeout_add_seconds

    This same thing occurs as root, I haven't a clue where to even begin troubleshooting this, so I came here before trying anything (in the hopes that I would not FUBAR the situation.)

    I:

    -am running SUSE Linux 10.1 (i586)
    -installed package pidgin-2.1.1-13.i586.rpm (as it was the latest rpm of pidgin I could find for my platform)
    -don't really know what other information is relevent.

    Again, I don't know where to begin troubleshooting this, and apologize for taking up anyones time if this problem has a simple fix, as I said I haven't a clue what's happening, so I would greatly appreciate any help.

     
    • Etan Reisner
      Etan Reisner
      2008-01-18

      You installed a version of pidgin compiled against a newer version of GTK+/glib then you have on your system, I'm going to guess you found the rpm you used on a random website and not from an official repository for your distribution. It is for this reason (and others as well) that I strongly recommend that people NOT use packages from random websites regardless of how above-board the site appears to be, claims to be, or is reputed to be. I would suggest you remove the packages you got from the site and install whatever version is the latest in the official repositories, if that version is not new enough for you then I would suggest you fetch the pidgin source rpm from our website and build an rpm from that yourself.

       
      • Spam3234
        Spam3234
        2008-01-19

        I believe I got this package from the official repository, it's been awhile since I got it though, I removed and re-installed it from the official site for sure this time.  As for GTK+/glib I updated them as well, and I am still getting this problem, so I don't know how it's still possible.

        Are there any ways I can determine the compatibility of pidgin to a particular version of GTK+/glib?  Or is there anywhere I could download packages of each that are compatible?

        If not, what do you recommend I do next?

        Thanks for your time and patience.

         
        • Etan Reisner
          Etan Reisner
          2008-01-19

          How did you install pidgin this time? What versions of pidgin, libpurple, glib, and gtk+ do you have installed? The versions GTK+ pidgin is compatible with depends on the versions it was compiled against.

           
          • Spam3234
            Spam3234
            2008-01-21

            I installed pidgin-2.1.1-13.i586.rpm, libpurple-2.1.1-13.i586.rpm, glib-1.2.10-672.i586.rpm, gtk-1.2.10-993.i586.rpm