#7 "make install" fails for 2.27

closed
nobody
None
5
2004-08-26
2004-07-11
Boris
No

Hello,

I've tried to compile the 2.27 plugin but it fails with
the following error:
--- ...
blist.c:64: warning: implicit declaration of function
`gaim_blist_node_action_new'
blist.c:64: warning: implicit declaration of function `_'
blist.c:70: error: `menu' undeclared (first use in this
function)
make: *** [blist.lo] Error 1
---

I am compiling on Debian (unstable), as you know. I
attach a file with more of the output.

HTH

Discussion

  • Boris
    Boris
    2004-07-11

     
    Attachments
  • Bill Tompkins
    Bill Tompkins
    2004-07-11

    Logged In: YES
    user_id=21203

    Did you install Gaim from source, or are you using the Gaim
    .deb? It looks as though the Debian package doesn't install
    the Gaim source files, so you'll need to install Gaim from
    source.

    I'm surprised that ./configure didn't fail, as it appears
    that the Gaim headers couldn't be found.

    -Bill

     
  • Boris
    Boris
    2004-07-12

    Logged In: YES
    user_id=475552

    I am using the .deb from APT, as the gaim-encryption .deb is
    not available for the latest version.

    Maybe update the install instructions/site text that suggest
    you can use packaged gaim when compiling? If there are no
    files with the APT.deb then there's probably not much else
    you can do.

     
  • Bill Tompkins
    Bill Tompkins
    2004-08-26

    • status: open --> closed