Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Plugin installed but not recognized by gaim

Help
kenan
2007-01-25
2013-04-22
  • kenan
    kenan
    2007-01-25

    I am running Fedora Core 6.  I installed gaim 2.0.0-0.26.beta5.fc6 with "yum install gaim".  I then downloaded source for gaim-encryption-3.0beta7 and successfully ran configure, make, make install (after installing gaim-devel and nss-devel).  But the plugin is not in the list when I run gaim.  Here is the relevant output of gaim -d:

    dbus: okkk
    plugins: probing /usr/lib/gaim/dbus-example.so
    plugins: probing /usr/lib/gaim/iconaway.so
    plugins: probing /usr/lib/gaim/statenotify.so
    plugins: probing /usr/lib/gaim/libmsn.so
    plugins: probing /usr/lib/gaim/libjabber.so
    plugins: probing /usr/lib/gaim/nautilus.so
    plugins: /usr/lib/gaim/nautilus.so is not loadable: The UI requirement is not met.
    plugins: probing /usr/lib/gaim/log_reader.so
    plugins: probing /usr/lib/gaim/gestures.so
    plugins: probing /usr/lib/gaim/gntgf.so
    plugins: /usr/lib/gaim/gntgf.so is not loadable: The UI requirement is not met.
    plugins: probing /usr/lib/gaim/idle.so
    plugins: probing /usr/lib/gaim/libzephyr.so
    plugins: probing /usr/lib/gaim/notify.so
    plugins: probing /usr/lib/gaim/ticker.so
    plugins: probing /usr/lib/gaim/ssl.so
    plugins: probing /usr/lib/gaim/ssl-nss.so
    plugins: probing /usr/lib/gaim/libsilcgaim.so
    plugins: probing /usr/lib/gaim/s.so
    plugins: /usr/lib/gaim/s.so is not loadable: undefined symbol: gg_blist_show
    plugins: /usr/lib/gaim/s.so is not usable because the 'gaim_init_plugin' symbol could not be found.  Does the plugin call the GAIM_INIT_PLUGIN() macro?
    plugins: probing /usr/lib/gaim/gevolution.so
    plugins: probing /usr/lib/gaim/libqq.so
    plugins: probing /usr/lib/gaim/psychic.so
    plugins: probing /usr/lib/gaim/liboscar.so
    plugins: probing /usr/lib/gaim/gaimrc.so
    plugins: probing /usr/lib/gaim/history.so
    plugins: probing /usr/lib/gaim/libyahoo.so
    plugins: probing /usr/lib/gaim/libgg.so
    plugins: probing /usr/lib/gaim/libsimple.so
    plugins: probing /usr/lib/gaim/ssl-gnutls.so
    plugins: probing /usr/lib/gaim/gntlastlog.so
    plugins: /usr/lib/gaim/gntlastlog.so is not loadable: undefined symbol: cur_term
    plugins: probing /usr/lib/gaim/timestamp.so
    plugins: probing /usr/lib/gaim/timestamp_format.so
    plugins: probing /usr/lib/gaim/perl.so
    plugins: probing /usr/lib/gaim/spellchk.so
    plugins: probing /usr/lib/gaim/libnovell.so
    plugins: probing /usr/lib/gaim/libirc.so
    plugins: probing /usr/lib/gaim/extplacement.so
    plugins: probing /usr/lib/gaim/musicmessaging.so
    plugins: probing /usr/lib/gaim/gnthistory.so
    plugins: /usr/lib/gaim/gnthistory.so is not loadable: The UI requirement is not met.
    util: Reading file accounts.xml from directory /home/kenan/.gaim
    util: Reading file status.xml from directory /home/kenan/.gaim
    stun: using server
    stun: using server
    sound: Initializing sound output drivers.
    util: Reading file blist.xml from directory /home/kenan/.gaim
    prefs: Reading /home/kenan/.gaim/prefs.xml
    prefs: Finished reading /home/kenan/.gaim/prefs.xml
    plugins: Loading saved plugin /usr/lib/gaim/extplacement.so
    prefs: /gaim/gtk/conversations/placement changed, scheduling save.
    plugins: Loading saved plugin /usr/lib/gaim/gaimrc.so
    plugins: Loading saved plugin /usr/lib/gaim/history.so
    plugins: Loading saved plugin /usr/lib/gaim/notify.so
    plugins: Loading saved plugin /usr/lib/gaim/ssl-nss.so
    plugins: Loading saved plugin /usr/lib/gaim/ssl.so
    gtkblist: added visibility manager: 1
    docklet: created
    pounce: Error reading pounces: Failed to open file '/home/kenan/.gaim/pounces.xml': No such file or directory
    Session Management: ICE initialized.
    Session Management: Connecting with no previous ID
    Session Management: Handling new ICE connection... done.

     
    • kenan
      kenan
      2007-01-28

      FYI, I never could get gaim-encryption-3.0beta7 working with gaim 2.0.0-0.26.beta5.fc6.  I ended up using gaim-encryption-3.0-0.1.beta6.fc6.rf from the dries repo and it's working fine. 

      http://mirror.atrpms.net/dries/fedora/fc6/i386/dries/RPMS/