Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Undefined symbol loading Gaim-Encryption

Help
2007-01-03
2013-04-22
  • Wesley Ribeiro
    Wesley Ribeiro
    2007-01-03

    I've compiled Gaim-Encryption 3.0beta7 to use with Gaim 2.0beta5. Everything went fine on the compilation, but the plugin can't be loaded due to a undefined symbol: gtk_widget_set_no_show_all.
    I'm on RH EL3 (I know that's old, but that's what I have to use). Can anyone help ?
    Regards,

    Wesley

     
    • hjheins
      hjheins
      2007-01-05

      Just a guess, but I think you need gtkmm as that contains gtk widgets.
      If you already have that installed, you might need a newer version.

       
      • Wesley Ribeiro
        Wesley Ribeiro
        2007-01-05

        I did a little more investigation and I believe that I should upgrade my Gtk2 version (I'm using 2.2.x and this symbol was included in 2.4.x).
        Meanwhile, I have commented-out the call to that function in Gaim-Encrypt code, and I was able to use the plugin. I'm sure that there will be some side-effect to this, but until now I haven't noticed any problems.

        Thanks,

        Wesley