#18 Fails to compile on Redhat 9 with Mozilla 1.4 packages

v1.0 (example)
closed-fixed
Bill Tompkins
5
2003-08-25
2003-08-20
Anonymous
No

Just tried to compile ver 2.06 on a RH9 box with
Mozilla-1.4 packages installed. (Have another box with
Mozilla-1.2.1 packages and compilation is fine)

Package list:

rpm -qa | grep moz
mozilla-nspr-1.4-3
mozilla-nss-1.4-3
mozilla-nspr-devel-1.4-3
mozilla-firebird-0.6-0.dag.rh90
mozilla-devel-1.4-3
mozilla-mail-1.4-3
mozilla-nss-devel-1.4-3
mozilla-1.4-3
mozilla-psm-1.4-3

calling configure with:
./configure
--with-nspr-includes=/usr/include/mozilla-1.4/nspr
--with-nss-includes=/usr/include/mozilla-1.4/nss
--with-nspr-libs=/usr/lib/mozilla-1.4
--with-nss-libs=/usr/lib/mozilla-1.4

Following error is produced:

<snip>
checking for NSPR include files...
/usr/include/mozilla-1.4/nspr/.
checking for NSS include files...
/usr/include/mozilla-1.4/nss/.
checking for PK11_GenerateKeyPair... no
checking: /usr/lib/mozilla-1.4/lib
checking: /usr/lib/mozilla-1.4/nspr
checking: /usr/lib/mozilla-1.4/lib/nspr
checking: NONE/lib
checking: NONE/nspr
checking: NONE/lib/nspr
checking: /lib/mozilla/lib
checking: /lib/mozilla/nspr
checking: /lib/mozilla/lib/nspr
checking: /opt/mozilla/lib
checking: /opt/mozilla/nspr
checking: /opt/mozilla/lib/nspr
checking: /usr/local/lib
checking: /usr/local/nspr
checking: /usr/local/lib/nspr
could not find nss3
configure: error: *** Cannot continue

Note the PK11_GenerateKeyPair says "no"

Hope I am not being a nong.

Discussion

  • Bill Tompkins
    Bill Tompkins
    2003-08-25

    • assigned_to: nobody --> obobo
    • status: open --> closed-fixed