Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#133 Can't send encrypted messages over AIM anymore

closed-invalid
Bill Tompkins
None
5
2008-03-01
2007-10-12
Mikey Cooper
No

Starting yesterday, a friend was unable to communicate with anyone encrypted. Any time anyone sent her a message, she only received the "*** Encrypted with the Gaim-Encryption plugin" message. I was able to communicate encrypted with others fine. This morning, myself and 5 other people who use gaim-encryption were all unable to talk amongst each other. The logs seem to show me sending the "Send Key" request (71 bytes received), but on the receiving end, the anchor tag is stripped out (46 bytes received).

Discussion

  • Mikey Cooper
    Mikey Cooper
    2007-10-12

    The log from me trying to send an encrypted message

     
  • Mikey Cooper
    Mikey Cooper
    2007-10-12

    The log when she received my encrypted message.

     
  • Mikey Cooper
    Mikey Cooper
    2007-10-12

    Logged In: YES
    user_id=970367
    Originator: YES

    File Added: receiver-purple-debug.log

     
  • brc64
    brc64
    2007-10-12

    Logged In: YES
    user_id=1407821
    Originator: NO

    We use the pidgin encryption plugin for internal office communication over AIM, and starting on the 10th we started having similar problems. First it was just one machine, then yesterday it happened to several more. I thought maybe Windows Updates may have been the cause, but then I saw one machine break before my eyes (the conversation started out okay, then all of the sudden everything was "Requesting key" or "*** Encrypted with the Gaim-Encryption plugin")

    Could AOL be doing something that would prevent this from working?

     
  • Bob Carroll
    Bob Carroll
    2007-10-12

    Logged In: YES
    user_id=1911742
    Originator: NO

    I'm noticing the same problem, starting today (October 12). I'm running Pidgin 2.2.1 with pidgin-encryption 3.0 on Windows.

     
  • saberspark77
    saberspark77
    2007-10-12

    Logged In: YES
    user_id=1596725
    Originator: NO

    My friend and I were having no trouble using encryption last night until 3AM. When we woke at 10AM, we were experiencing the same issues. Neither of us could have encryption turned on without receiving "*** Encrypted with the Gaim-Encryption plugin" on the receiving end and "Requesting key..." on the other.

    We attempted updates to pidgin, reinstallation of pidgin-encryption, and forced key updates via deletion as potential solutions, none of which were effective.

     
  • saberspark77
    saberspark77
    2007-10-12

    Logged In: YES
    user_id=1596725
    Originator: NO

    Right, version 2.2.1 and p-e version 3.0 in Vista.

     
  • Mikey Cooper
    Mikey Cooper
    2007-10-13

    • status: open --> closed
     
  • Mikey Cooper
    Mikey Cooper
    2007-10-13

    Logged In: YES
    user_id=970367
    Originator: YES

    Issue resolved itself this afternoon. Everyone I've tried speaking to that was having the issue no longer seems to be having it.

     
  • Bill Tompkins
    Bill Tompkins
    2007-10-22

    Logged In: YES
    user_id=21203
    Originator: NO

    Yes, this issue was caused by some changes in the AIM servers, and seems to be resolved at this point. If anyone is still seeing this problem, please let me know.

    Thanks,

    -Bill

     
  • Bill Tompkins
    Bill Tompkins
    2007-10-22

    • assigned_to: nobody --> obobo
    • status: closed --> pending-out-of-date
     
  • Mikey Cooper
    Mikey Cooper
    2007-10-24

    • status: pending-out-of-date --> open-out-of-date
     
  • Mikey Cooper
    Mikey Cooper
    2007-10-24

    Logged In: YES
    user_id=970367
    Originator: YES

    This started happening again yesterday to a few of the people on my buddylist and now today to everyone, including myself.

     
  • brant williams
    brant williams
    2007-10-25

    Logged In: YES
    user_id=1921607
    Originator: NO

    Several people I know, including myself, are experiencing this same issue again today. If more information is required, please let me know.

    Thanks!

    -brant

     
  • DrewgieFly
    DrewgieFly
    2007-10-25

    Logged In: YES
    user_id=1921781
    Originator: NO

    It definitely looks like an AIM server issue, however it only seems to affect specific servers. I don't know how AIM handles connections, but it seems as though a screen name is attached to a single specific server that does not change often (at least my connection has not changed in the past 24 hours). At my workplace most folks are not having any issues; we are all connecting to different servers and mine seems to be one of the lucky ones where the encryption does not work. This same situation happened to me a couple of weeks ago, when this issue was first reported. If any more information is needed I'd be glad to provide it. Unfortunately it looks like this might be outside of the Pidgin-Encryption code itself.

     
  • brant williams
    brant williams
    2007-10-25

    Logged In: YES
    user_id=1921607
    Originator: NO

    Interesting. Here are the servers I'm currently using.

    C:\Documents and Settings\brant>netstat -n -p tcp | find "5190"
    TCP 192.168.69.123:1628 205.188.13.44:5190 ESTABLISHED
    TCP 192.168.69.123:2698 205.188.9.157:5190 ESTABLISHED
    TCP 192.168.69.123:2718 205.188.248.146:5190 ESTABLISHED

     
  • Scott Dataczar
    Scott Dataczar
    2007-10-25

    Logged In: YES
    user_id=1656365
    Originator: NO

    same problem here:
    64.12.160.141:5190 ESTABLISHED13100/pidgin
    205.188.153.2:5190 ESTABLISHED13100/pidgin
    64.12.30.60:5190 ESTABLISHED13100/pidgin
    64.12.24.104:5190 ESTABLISHED13100/pidgin
    64.12.201.42:5190 ESTABLISHED13100/pidgin

     
  • Joe C
    Joe C
    2007-10-25

    Logged In: YES
    user_id=1921937
    Originator: NO

    I'm running
    Pidgin 2.2.2 with pidgin-encryption 3.0 on Windows, and I'm getting the same thing as everyone else.

     
  • Bill Tompkins
    Bill Tompkins
    2007-10-26

    Logged In: YES
    user_id=21203
    Originator: NO

    Current SVN has a change to the headers used with the AIM protocol, which provides a fix. However, it is not compatible with previous versions of the plugin when used with AIM.

    If I can't find a way to make it backwards compatible as well, I'll release it as 3.1 this weekend.

    -Bill

     
  • Bill Tompkins
    Bill Tompkins
    2007-10-26

    • status: open-out-of-date --> open
     
  • Mikey Cooper
    Mikey Cooper
    2007-10-27

    Logged In: YES
    user_id=970367
    Originator: YES

    Yesterday afternoon, encryption started working again for me. I'm still hoping for a new version with headers that will work if/when aim decides to start stripping the empty anchor tags again.

     
  • Logged In: YES
    user_id=725384
    Originator: NO

    Some thoughts:

    - Is this workaround still needed? I'm not seeing the issue anymore (which makes me suspect there were problems on the AOL servers), and having incompatible methods is a bad idea at the moment.

    - If it is thought advantageous to have a protocol that won't break when HTML is stripped, it might be worth setting up some kind of fallback so new versions can still communicate on the old protocol if the other side is using an older version, or if they get a message using the old protocol.

     
  • Mikey Cooper
    Mikey Cooper
    2008-03-01

    Logged In: YES
    user_id=970367
    Originator: YES

    Workaround not needed anymore. Closing.

     
  • Mikey Cooper
    Mikey Cooper
    2008-03-01

    • status: open --> closed-invalid