Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#13 Not working over Jabber?

closed-works-for-me
Bill Tompkins
None
5
2003-07-31
2003-07-30
wabu
No

Gaim-Encryption 2.02 (compiled with 0.66)
Key: Private 1024 NSS 1.0
Using Jabber protocol plus ICQ and AIM transports.

I mainly use gaim with the Jabber protocol, when I
tried gaim-encryption, it creates the key fine but
actually trying to talk to someone never works.

I can switch to "Tx: secure" in the message window, but
when I send a message I see in the message window
"Requesting key..." but nothing happens. I don't get a
dialog box pop-up like I do when using the ICQ protocol
with Gaim.

If a user tries to send a encrypted message to me they
see "(18:44:07) wataru: *** Encrypted with the
Gaim-Encryption plugin".

I've tested this with two users via Jabber and got the
same result.
But I can talk to one of the users fine if I use just
the ICQ protocol (seperate Gaim "Account" for ICQ).

Discussion

  • Bill Tompkins
    Bill Tompkins
    2003-07-30

    Logged In: YES
    user_id=21203

    Jabber was broken in 2.00 and 2.01: verify that the people
    you're chatting with have v2.02. The way to check is in the
    "Preferences" window, click on the "Plugins" label, then on
    the "Gaim-Encryption" label next to the check box. You
    should see a screen saying "Gaim-Encryption 2.02 (compiled
    with 0.66)".

    There is an RPM named gaim-encryption-2.0-2.rpm which is NOT
    v.2.0.2, it is v2.0. I'll try to get that updated.

    I have tested it several times, and 2.0.2 does work for me
    with Jabber (although the "broadcast" packet makes the first
    message look like a URL). You can test it with your own
    account by sending an IM to yourself: it looks a little
    funny getting both directions in the same window, but it
    does work.

    If v2.0.2 is not working for you, IM me at billTtest@jabber.org.

     
  • Bill Tompkins
    Bill Tompkins
    2003-07-30

    • status: open --> pending-works-for-me
     
  • Bill Tompkins
    Bill Tompkins
    2003-07-30

    • assigned_to: nobody --> obobo
     
  • wabu
    wabu
    2003-07-31

    • status: pending-works-for-me --> open-works-for-me
     
  • wabu
    wabu
    2003-07-31

    Logged In: YES
    user_id=270620

    I've asked one of them and they are using 2.00 so I'll be
    nagging them to upgrade :)

    Thanks.

     
  • Bill Tompkins
    Bill Tompkins
    2003-07-31

    • status: open-works-for-me --> closed-works-for-me