Hi Frank,

I'm the Debian Maintainer for PHPwiki, so I'll see if I can help you out.

On 3/15/07, Frank Van Damme < frank.vandamme@gmail.com> wrote:
I have a phpwiki running. It's on version 1.3.4 and when I upgraded my
distribution to Debian Etch lately, phpwiki stopped serving me wiki
pages but opted for error messages instead. They probably have
something to do with php being upgraded, but I'm not too concerned
about *that*.

That's not very good. What version of the package were you upgrading from? If you can send me some details about teh upgrade process, versions, database backend, error messages, etc. I'll be happy to look into it and make sure it's not a bug in the package. I have not had any other failed upgrade reports recently.

That doesn't work for me. I get asked to sign in. I enter the values of
ADMIN_USER and ADMIN_PASSWD in /etc/phpwiki/config.ini respectively.
The result:

Fatal Error:
lib/WikiDB/backend/PearDB.php:1032: Error:
WikiDB_backend_PearDB_mysql: fatal database error
DB Error: no such table
(SELECT prefs FROM pref WHERE userid='phpwiki' [nativecode=1146 **
Table 'phpwiki.pref' doesn't exist])

Is this while trying to load upgrade.php?
 
Cheers

--
Matt Brown
matt@mattb.net.nz
Mob +64 21 611 544 www.mattb.net.nz